[PAT乙级]1009 说反话

Posted Wecccccccc

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PAT乙级]1009 说反话相关的知识,希望对你有一定的参考价值。

给定一句英语,要求你编写程序,将句中所有单词的顺序颠倒输出。
输入格式:

测试输入包含一个测试用例,在一行内给出总长度不超过 80 的字符串。字符串由若干单词和若干空格组成,其中单词是由英文字母(大小写有区分)组成的字符串,单词之间用 1 个空格分开,输入保证句子末尾没有多余的空格。
输出格式:

每个测试用例的输出占一行,输出倒序后的句子。
输入样例:


Hello World Here I Come

输出样例:

Come I Here World Hello

代码如下:

#include <iostream>
#include <string>
#include <stack>
#include <cstring>
using namespace std;

int main()
{
	string str;
	getline(cin,str);
	stack<string>s;
	int idx = 0;
	for (int i = 0; i < str.length(); i = idx)
	{
		string tmp = "";
		 idx = i;
		 while (str[idx] != ' ' && idx < str.length())
		{
			tmp += str[idx];
			idx++;
		}
		s.push(tmp);
		idx++;
	}
	while (s.size())
	{
		cout << s.top() ;
		if (s.size() != 1)
		{
			cout << " ";
		}
		s.pop();
	}
	return 0;
}

代码如下:

#include <iostream>
#include <string>
#include <stack>
#include <cstring>

using namespace std;

int main()
{
	stack<string>s;
	string str;
	while (cin >> str)
	{
		s.push(str);
	}

	while (s.size())
	{
		cout << s.top();
		if (s.size() != 1) cout << " ";
		s.pop();
	}
	return 0;
}

以上是关于[PAT乙级]1009 说反话的主要内容,如果未能解决你的问题,请参考以下文章

PAT-乙级-1009 说反话

PAT乙级1009.说反话(20)

[PAT乙级]1009 说反话

PAT乙级1009

PAT 乙级 1009

PTA 乙级 1009 说反话