[PTA]习题8-8 判断回文字符串
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]习题8-8 判断回文字符串相关的知识,希望对你有一定的参考价值。
[PTA]习题8-8 判断回文字符串
本题要求编写函数,判断给定的一串字符是否为“回文”。所谓“回文”是指顺读和倒读都一样的字符串。如“XYZYX”和“xyzzyx”都是回文。
函数接口定义:
bool palindrome( char *s );
函数palindrome判断输入字符串char *s是否为回文。若是则返回true,否则返回false。
裁判测试程序样例:
#include <stdio.h>
#include <string.h>
#define MAXN 20
typedef enum {false, true} bool;
bool palindrome( char *s );
int main()
{
char s[MAXN];
scanf("%s", s);
if ( palindrome(s)==true )
printf("Yes\\n");
else
printf("No\\n");
printf("%s\\n", s);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例1:
thisistrueurtsisiht
输出样例1:
Yes
thisistrueurtsisiht
输入样例2:
thisisnottrue
输出样例2:
No
thisisnottrue
- 提交结果:
- 源码:
#include <stdio.h>
#include <string.h>
#define MAXN 20
typedef enum { false, true } bool;
bool palindrome(char* s);
int main()
{
char s[MAXN];
scanf("%s", s);
if (palindrome(s) == true)
printf("Yes\\n");
else
printf("No\\n");
printf("%s\\n", s);
return 0;
}
/* 你的代码将被嵌在这里 */
bool palindrome(char* s)
{
int len = strlen(s);
// len为字符串长度,作为数组下标时,len需减1
len--;
for (int i = 0; i < len; i++, len--)
{
// 首尾依次相比较,不同则不是回文字符
if (s[i] != s[len])
{
return false;
}
}
return true;
}
以上是关于[PTA]习题8-8 判断回文字符串的主要内容,如果未能解决你的问题,请参考以下文章