用C语言怎么判断一个字符串是不是为空?
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了用C语言怎么判断一个字符串是不是为空?相关的知识,希望对你有一定的参考价值。
在百度上搜索得来的结果是用 if(strlen(变量)==0),但是那样如果你输入的是空格,会判断不出来的,那位高人来指点下?!!
空格不算是空字符串,str=""这样的才算是空字符串,里面什么都没有,而str=" "是有内容了,这个str存储了一个字符(空格),如果你要把空格也算是空字符串,那么要稍作修改:char str[] = " ";
int len = strlen(str), i = 0;
if (len > 0)
while(i < len && str[i++] == ' ');
if (i < len) // 字符串不空
else // 空字符串
参考技术A 空格和字符串为空的概念本来就不一样,
如楼上所说空格本来就代表一个字符,
而空字符串直接为"\0"
如果你要把空格的字符串也定义为空字符串的话
就要加判断
空格的ASCII码为32
你只需要再多加一个遍历判断就OK
int IsEmpty = 0;
int length = strlen(变量);
int n;
//遍历整个字符串,如果全为空格,则返回字符串也为空
for(n=0;n<length;n++)
//判断ASCII码是否为32
if(变量[n]==32)
IsEmpty=1;
else
IsEmpty=0;
//存在一个字符则跳出循环
break;
if(length == 0)
printf("字符串为空");
else if(IsEmpty)
printf("字符串为空");
else
printf("字符串不为空"); 参考技术B 如果你输入了空格,字符串严格来说就应该不为空了,空格也是有对应的ASCII码值的,32!char的存储范围是0~255(ASCII)间的字符都可以存在char型数据中。因此你输入一个空格后这个字符串就不为空了,这个字符串实际是" \0",一个空字符串相当于"\0",看到区别了吗?空格也是一个字符啊!这点必须要明确! 参考技术C 空字符串的长度为0,那就是说第一个字符是'\0',所以可以用下面的代码行判断:
char str1[]="",str2[]="abc";
printf(str1[0]=='\0' ? "str1是空字符串\n" : "str1是非空字符串\n");
printf(str2[0]=='\0' ? "str2是空字符串\n" : "str2是非空字符串\n"); 参考技术D 空格和字符串为空的概念本来就不一样,
如楼上所说空格本来就代表一个字符,
而空字符串直接为"\0"
如果你要把空格的字符串也定义为空字符串的话
就要加判断
空格的ASCII码为32
你只需要再多加一个遍历判断就OK
int IsEmpty = 0;
int length = strlen(变量);
int n;
//遍历整个字符串,如果全为空格,则返回字符串也为空
for(n=0;n<length;n++)
//判断ASCII码是否为32
if(变量[n]==32)
IsEmpty=1;
else
IsEmpty=0;
//存在一个字符则跳出循环
break;
if(length == 0)
printf("字符串为空");
else if(IsEmpty)
printf("字符串为空");
else
printf("字符串不为空");
C语言中怎么判定输入是不是为空
原题如下
Calculate a + b
Input
The input will consist of a series of pairs of integers a and b,separated by a space, one pair of integers per line.
Output
For each pair of input integers a and b you should output the sum of a and b in one line,and with one line of output for each line in input.
Sample Input
1 5
Sample Output
6
Hint:
Q:Where is the input and the output?
A:Your program shall read input from stdin('Standard Input') and write output to stdout('Standard Output').For example,you can use 'scanf' in C or 'cin' in C++ to read from stdin,and use 'printf' in C or 'cout' in C++ to write to stdout.
User programs are not allowed to open and read from/write to files, you will get a "Runtime Error" if you try to do so.
不行...提交了答案还是提示Runtime Error
1.使用strlen函数来判断输入是否为空,如果返回值为0,就是空。
strlen做的是一个计数器的工作,它从内存的某个位置(可以是字符串开头,中间某个位置,甚至是某个不确定的内存区域)开始扫描,直到碰到第一个字符串结束符'\\0'为止,然后返回计数器值(长度不包含“\\0”)。
原 型:extern unsigned int strlen(char *s);
头文件:string.h
格 式:strlen (字符数组名)
功 能:计算字符串s的(unsigned int型)长度,不包括'\\0'在内
说 明:返回s的长度,不包括结束符NULL。
2.例程:
#include <string.h>
int main()
char s[1000];
while (gets(s)!=NULL) //循环读入s
if(0<strlen(s)) //根据判断输出输入是否为空
printf ("%s 不为空",s);
else
printf ("%s 为空",s);
return 0;
参考技术A ACM吧
#include <iostream>
#incldue <cstdlib>
using namespace std;
int main()
int a,b;
while(cin>>a>>b)
cout<<a+b<<endl;
就行了
或者while里改成
while((scanf(%d %d,&a,&b))!=EOF)
scanf()里规定了输入两个数之间是空格
而用cin可以不用管 c++的io流很强大 不需要做这种考虑
但是scanf明显比cin快本回答被提问者采纳 参考技术B 既然是英文题我很喜欢,虽然分不多,这道题说输入函数可以用cin 或scanf
我就用scanf解答
scanf("%d %d",&a,&b); 这样输入的时候是a b 注意是空格之间的格式 哦了
楼上的没看懂题吧
lz可能想判断中间的空格吧 ,不过这题不是这样的 参考技术C 不用考虑输入为空,程序会暂停等待输入 参考技术D if(变量=NULL)
以上是关于用C语言怎么判断一个字符串是不是为空?的主要内容,如果未能解决你的问题,请参考以下文章