Counterfeit Dollar

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Counterfeit Dollar相关的知识,希望对你有一定的参考价值。


Problem Description


Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.


 



Input


The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up, ``down, or ``even. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.


 



Output


For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.


 



Sample Input


1 
ABCD EFGH even
ABCI EFJK up
ABIJ EFGH even


 



Sample Output


K is the counterfeit coin and it is light.


 



题目大意:有一打(12枚)硬币,其中有且仅有1枚假币,11枚真币用A~L作为各个硬币的代号

假币可能比真币略轻,也可能略重            现在利用天枰,根据Input输入的3次称量,找出假币,并输出假币是轻还是重。




#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
string a,b,c;
int m[20];
int v[20];
int abs(int x)

return x<0?-x:x;

int main()

int t;
scanf("%d",&t);
while(t--)

memset(m,0,sizeof(m));
memset(v,0,sizeof(v));
for(int i=0;i<3;i++)

cin>>a>>b>>c;
if(c=="even")

for(int j=0;a[j];j++)
m[a[j]-A]=1;
for(int j=0;b[j];j++)
m[b[j]-A]=1;

if(c=="up")

for(int j=0;a[j];j++)
v[a[j]-A]++;
for(int j=0;b[j];j++)
v[b[j]-A]--;

if(c=="down")

for(int j=0;a[j];j++)
v[a[j]-A]--;
for(int j=0;b[j];j++)
v[b[j]-A]++;


// for(int i=0;i<12;i++)
// cout<<char(char(i)+A)<<" ";
// // cout<<endl;
// for(int i=0;i<12;i++)
// cout<<v[i]<<" ";
// cout<<endl;
int k=-1,ans=0,flag=0;
for(int i=0;i<12;i++)

if(m[i])continue;
if(k<abs(v[i]))

k=abs(v[i]);
ans=i;
flag=v[i];


printf("%c is the counterfeit coin and it is %s.\\n",ans+A,flag>0?"heavy":"light");

return 0;




以上是关于Counterfeit Dollar的主要内容,如果未能解决你的问题,请参考以下文章

D - Counterfeit Dollar(第二季水)

九度[1150]Counterfeit Dollar

1013 Counterfeit Dollar

2692 假币问题(枚举——数学模型中包含多个变量)

3_寻找假币问题(分治法)

假币问题