hdu 5698 瞬间移动(2016"百度之星" - 初赛(Astar Round2B)——数学题)

Posted qiqi_starsky

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 5698 瞬间移动(2016"百度之星" - 初赛(Astar Round2B)——数学题)相关的知识,希望对你有一定的参考价值。

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5698

瞬间移动

 
 Accepts: 1018
 
 Submissions: 3620
 Time Limit: 4000/2000 MS (Java/Others)
 
 Memory Limit: 65536/65536 K (Java/Others)
Problem Description

有一个无限大的矩形,初始时你在左上角(即第一行第一列),每次你都可以选择一个右下方格子,并瞬移过去(如从下图中的红色格子能直接瞬移到蓝色格子),求到第nn行第mm列的格子有几种方案,答案对10000000071000000007取模。

技术分享

Input

多组测试数据。

两个整数n,m(2\leq n,m\leq 100000)n,m(2n,m100000)

Output

一个整数表示答案

Sample Input
4 5
Sample Output
10
解题思路:找规律,推出一个类似杨辉三角的图形,精确的说是斜着杨辉三角的一半,根据杨辉三角的规律求结果。

规律为:技术分享

详见代码。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
const int mod=1e9+7;
typedef long long ll;
//返回d=gcd(a,b);和对应于等式ax+by=d中的x,y
ll extend_gcd(ll a,ll b,ll &x,ll &y)
{
    if(a==0&&b==0) return -1;//无最大公约数
    if(b==0){x=1;y=0;return a;}
    ll d=extend_gcd(b,a%b,y,x);
    y-=a/b*x;
    return d;
}
//*********求逆元素*******************
//ax = 1(mod n)
ll mod_reverse(ll a,ll n)
{
    ll x,y;
    ll d=extend_gcd(a,n,x,y);
    if(d==1) return (x%n+n)%n;
    else return -1;
}

ll c(ll m,ll n)
{
    ll i,j,t1,t2,ans;
    t1=t2=1;
    for(i=n;i>=n-m+1;i--) t1=t1*i%mod;
    for(i=1;i<=m;i++) t2=t2*i%mod;
    return  t1*mod_reverse(t2,mod)%mod;
}
int main()
{
    ll n,m;
    while(~scanf("%lld%lld",&n,&m))
    {
        if(n<m) swap(n,m);
        printf("%lld\n",c(m-2,n+m-4));
    }
     return 0;
}




以上是关于hdu 5698 瞬间移动(2016"百度之星" - 初赛(Astar Round2B)——数学题)的主要内容,如果未能解决你的问题,请参考以下文章

hdu5698瞬间移动(组合数,逆元)

hdu-5698 瞬间移动(数论+快速幂)

hdu5698瞬间移动(杨辉三角+快速幂+逆元)

hdu_5698_瞬间移动

HDU 5698 大组合数取模(逆元)

hdu5698 百度之星2016round2b第3题