A.1081 Rational Sum (20)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了A.1081 Rational Sum (20)相关的知识,希望对你有一定的参考价值。

?????????simple   form   pre   spec   problem   follow   ==   with   out   

1081 Rational Sum (20)???20 ??????

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

#include<stdio.h>
#include<math.h>
typedef long long ll;

struct Fraction {
    ll up, down;
}f[110],result;

ll gcd(ll a, ll b) {
    if (b == 0) return a;
    else return gcd(b, a % b);
}

Fraction Reducation(Fraction result) {     //???Fraction!!!??????int????????????
    if (result.down < 0) {
        result.up = -result.up;
        result.down = -result.down;
    }
    if (result.up == 0) {
        result.down = 1;
    }
    else {
        ll d = gcd(abs(result.up), abs(result.down));
        result.up /= d;
        result.down /= d;
    }
    return result;
}
void Output(Fraction result) {
    if (result.up == 0) {
        printf("0");
    }
    else if (result.down == 1) {
        printf("%lld\n", result.up);
    }
    else if (result.up > result.down) {
        printf("%lld %lld/%lld\n", result.up / result.down, result.up % result.down, result.down);
    }
    else {
        printf("%lld/%lld\n", result.up, result.down);
    }
}

int main() {
    int n;
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
        scanf("%lld/%lld", &f[i].up, &f[i].down);
    }
    result.up = f[0].up; result.down = f[0].down;
    for (int i = 1; i < n; i++) {
        result.up = result.up * f[i].down + f[i].up * result.down;
        result.down = result.down * f[i].down;
    }
    result = Reducation(result);
    Output(result);
    return 0;
}

 

以上是关于A.1081 Rational Sum (20)的主要内容,如果未能解决你的问题,请参考以下文章

1081 Rational Sum (20 分)分数加法

1081 Rational Sum(20 分)

1081. Rational Sum (20) -最大公约数

1081. Rational Sum (20)模拟——PAT (Advanced Level) Practise

Rational Sum (20)

[PAT] 1081 Rational Sum (20 分)Java