1030 Travel Plan (30)(30 分)

Posted 给杰瑞一块奶酪~

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1030 Travel Plan (30)(30 分)相关的知识,希望对你有一定的参考价值。

A traveler‘s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output

0 2 3 3 40


dijkstra算法,距离相同情况下,选消费少的,记录路径即可。
代码:
技术分享图片
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#include <set>
#include <map>
#define inf 0x3f3f3f3f
#define MAX 501
using namespace std;
int n,m,s,d,tdis,tcost,a,b;
int edis[MAX][MAX];
int ecost[MAX][MAX];
int dis[MAX];
int cost[MAX];
int vis[MAX];
int path[MAX];
void print(int k) {
    if(k == s)return;
    print(path[k]);
    printf(" %d",k);
}
int main() {
    scanf("%d%d%d%d",&n,&m,&s,&d);
    for(int i = 0;i < n;i ++) {
        for(int j = 0;j < n;j ++)
            edis[i][j] = inf;
        edis[i][i] = 0;
        dis[i] = inf;
    }
    for(int i = 0;i < m;i ++) {
        scanf("%d%d%d%d",&a,&b,&tdis,&tcost);
        edis[a][b] = edis[b][a] = tdis;
        ecost[a][b] = ecost[b][a] = tcost;
    }
    dis[s] = 0;
    int t,mi;
    while(1) {
        t = -1;
        mi = inf;
        for(int i = 0;i < n;i ++) {
            if(!vis[i] && dis[i] < mi)mi = dis[i],t = i;
        }
        if(t == -1)break;
        vis[t] = 1;
        for(int i = 0;i < n;i ++) {
            if(vis[i] || edis[t][i] == inf)continue;
            if(mi + edis[t][i] < dis[i]) {
                dis[i] = mi + edis[t][i];
                cost[i] = cost[t] + ecost[t][i];
                path[i] = t;
            }
            else if(mi + edis[t][i] == dis[i] && cost[t] + ecost[t][i] < cost[i]) {
                cost[i] = cost[t] + ecost[t][i];
                path[i] = t;
            }
        }
    }
    printf("%d",s);
    print(d);
    printf(" %d %d",dis[d],cost[d]);
}
View Code

 

以上是关于1030 Travel Plan (30)(30 分)的主要内容,如果未能解决你的问题,请参考以下文章

1030 Travel Plan (30 分)

1030 Travel Plan (30)

1030. Travel Plan (30)

1030. Travel Plan (30)

1030 Travel Plan (30分)

PAT (Advanced Level) 1030. Travel Plan (30)