Problem A: 求个最大值

Posted 一本故事i

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Problem A: 求个最大值相关的知识,希望对你有一定的参考价值。

 

Problem A: 求个最大值

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 1635  Solved: 1339
[Submit][Status][Web Board]

Description

定义MaxValue类,用于求一系列非零整数的最大值。其中:

1. 数据成员elements用于存储所有输入的非零整数。

2. void append(int)用于向elements中添加一个新数据。

3. int getMax()用于求出elements中的最大值。

 

Input

输入若干个整数,以输入0表示输入结束。

 

Output

所有输入的非零整数中的最大值。

 

Sample Input

321
496
553
338
837
463
158
154
929
537
0

  

Sample Output

929

HINT

 

使用vector更为容易实现。


 

 

Append Code

append.cc
int main()
{
    int a;
    MaxValue test;
    cin>>a;
    while (a != 0)
    {
        test.append(a);
        cin>>a;
    }
    cout<<test.getMax()<<endl;
    return 0;
}

  

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
class MaxValue
{
public :
    vector<int> elements;
    void append(int num)
    {
        elements.push_back(num);
    }
     int getMax()
     {
         sort(elements.begin(), elements.end());//排序
         return elements.back();//返回最后一个元素
     }
};
int main()
{
    int a;
    MaxValue test;
    cin>>a;
    while (a != 0)
    {
        test.append(a);
        cin>>a;
    }
    cout<<test.getMax()<<endl;
    return 0;
}

  

以上是关于Problem A: 求个最大值的主要内容,如果未能解决你的问题,请参考以下文章

1010 求个最大值

noip提高组2013 火柴排队

Java求个员工的年龄29,33,34,40的平均年龄和最大最小值

loj6158 A+B Problem (扩展KMP)

hdu 4267 A Simple Problem with Integers

android小知识点代码片段