POJ1008 Maya Calendar
Posted 参婵
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ1008 Maya Calendar相关的知识,希望对你有一定的参考价值。
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 82185 | Accepted: 25234 |
Description
For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.
Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:
1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .
Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:
Haab: 0. pop 0
Tzolkin: 1 imix 0
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.
Input
NumberOfTheDay. Month Year
The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.
Output
Number NameOfTheDay Year
The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.
Sample Input
3 10. zac 0 0. pop 0 10. zac 1995
Sample Output
3 3 chuen 0 1 imix 0 9 cimi 2801
Source
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
char Haab[19][10]={"pop","no","zip","zotz","tzec","xul","yoxkin","mol","chen","yax","zac","ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"},
Tzolkin[20][10]={"imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk","ok","chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"};
int main()
{
int N,i,j;
int num,yr,ndays,mon;
char name[10],ch;
scanf("%d",&N);
printf("%d\n",N);
for(i=0;i<N;i++)
{
cin>>num>>ch>>name>>yr;
for(j=0;j<19;j++)
if(!strcmp(Haab[j],name))
{
break;
}
ndays=365*yr+j*20+num;
yr=ndays/260;
num=ndays%260%13+1;
mon=ndays%260%20;
if(!ndays%260&&ndays)
yr--;
cout<<num<<‘ ‘<<Tzolkin[mon]<<‘ ‘<<yr<<endl;
}
return 0;
}
以上是关于POJ1008 Maya Calendar的主要内容,如果未能解决你的问题,请参考以下文章
[POJ] #1008# Maya Calendar : 字符处理/同余问题