HDU 3440 House Man

Posted 一蓑烟雨任生平

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 3440 House Man相关的知识,希望对你有一定的参考价值。

House Man

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3174    Accepted Submission(s): 1325


Problem Description
In Fuzhou, there is a crazy super man. He can’t fly, but he could jump from housetop to housetop. Today he plans to use N houses to hone his house hopping skills. He will start at the shortest house and make N-1 jumps, with each jump taking him to a taller house than the one he is jumping from. When finished, he will have been on every house exactly once, traversing them in increasing order of height, and ending up on the tallest house.
The man can travel for at most a certain horizontal distance D in a single jump. To make this as much fun as possible, the crazy man want to maximize the distance between the positions of the shortest house and the tallest house.
The crazy super man have an ability—move houses. So he is going to move the houses subject to the following constraints:
1. All houses are to be moved along a one-dimensional path.
2. Houses must be moved at integer locations along the path, with no two houses at the same location.
3. Houses must be arranged so their moved ordering from left to right is the same as their ordering in the input. They must NOT be sorted by height, or reordered in any way. They must be kept in their stated order.
4. The super man can only jump so far, so every house must be moved close enough to the next taller house. Specifically, they must be no further than D apart on the ground (the difference in their heights doesn‘t matter).
Given N houses, in a specified order, each with a distinct integer height, help the super man figure out the maximum possible distance they can put between the shortest house and the tallest house, and be able to use the houses for training.
 

 

Input
In the first line there is an integer T, indicates the number of test cases.(T<=500)
Each test case begins with a line containing two integers N (1 ≤ N ≤ 1000) and D (1 ≤ D ≤1000000). The next line contains N integer, giving the heights of the N houses, in the order that they should be moved. Within a test case, all heights will be unique.
 

 

Output
For each test case , output “Case %d: “first where d is the case number counted from one, then output a single integer representing the maximum distance between the shortest and tallest house, subject to the constraints above, or -1 if it is impossible to lay out the houses. Do not print any blank lines between answers.
 

 

Sample Input
3 4 4 20 30 10 40 5 6 20 34 54 10 15 4 2 10 20 16 13
 

 

Sample Output
Case 1: 3 Case 2: 3 Case 3: -1
 

 

Author
jyd
 

 

Source
 

 

Recommend
We have carefully selected several similar problems for you:  3439 3433 3442 3438 3437 
#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 1100
#define MAXM MAXN*MAXN
#define INF 0x7fffffff
using namespace std;
queue<int>que;
int t,n,d,tot,kase;
int dis[MAXN],vis[MAXN],num[MAXN],id;
int to[MAXM],net[MAXM],cap[MAXM],head[MAXN];
struct House{ int high;int no; }arr[MAXN];
int cmp(House a,House b){ return a.high<b.high; }
void add(int u,int v,int w){ to[++tot]=v;cap[tot]=w;net[tot]=head[u];head[u]=tot; }
int spfa(int s,int t,int n){
    memset(num,0,sizeof(num));
    memset(vis,0,sizeof(vis));
    memset(dis,0x7f,sizeof(dis));
    while(!que.empty())    que.pop();
    dis[s]=0;vis[s]=1;que.push(s);
    while(!que.empty()){
        int now=que.front();
        que.pop();
        vis[now]=0;num[now]++;
        if(num[now]>n) return -1;
        for(int i=head[now];i;i=net[i]){
            if(dis[to[i]]>dis[now]+cap[i]){
                dis[to[i]]=dis[now]+cap[i];
                if(!vis[to[i]]){
                    vis[to[i]]=1;
                    que.push(to[i]);
                }
            }
        }
    }
    return dis[t];
}
int main(){
    scanf("%d",&t);
    while(t--){
        memset(head,0,sizeof(head));
        scanf("%d%d",&n,&d);tot=0;
        for (int i=1;i<=n;i++){
            scanf("%d",&arr[i].high);
            arr[i].no=i;
            if(i!=n)    add(i+1,i,-1);
        }
        sort(arr+1,arr+n+1,cmp);
        for(int i=1;i<n;i++){
            int u=arr[i].no;
            int v=arr[i+1].no;
            if(u>v) swap(u,v);
            add(u,v,d);
        }
        int u=arr[1].no,v=arr[n].no;
        if(u>v)    swap(u,v);
        printf("Case %d: %d\n",++kase,spfa(u,v,n));
    }
}

 

以上是关于HDU 3440 House Man的主要内容,如果未能解决你的问题,请参考以下文章

hdu3440 House Man 差分约束系统

hdu 3440 House Man

HDU 3440 House Man

HDOJ题目3440 House Man(差分约束)

POJ-2195 Going Home---KM算法求最小权值匹配(存负边)

HDU 5538 House Building(模拟——思维)