The kth great number(set)

Posted handsomecui

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了The kth great number(set)相关的知识,希望对你有一定的参考价值。

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 9407    Accepted Submission(s): 3752


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
 

 

Sample Input
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

 

Sample Output
1 2 3
Hint
Xiao Ming won‘t ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
 题解:只需要维护前K大数就好了;
代码:
#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
#include<set>
#include<vector>
#define INF 0x3f3f3f3f
using namespace std;

struct Node{
    int v;
    friend bool operator < (Node a, Node b){
        return a.v > b.v;
    }
};
multiset<Node>st;
multiset<Node>::iterator iter;

int main(){
    int n, k;
    char s[2];
    Node d;
    while(~scanf("%d%d", &n, &k)){
        st.clear();
        int ans = 0x3f3f3f3f;
        for(int i = 0; i < n; i++){
            scanf("%s", s);
            if(s[0] == I){
                scanf("%d", &d.v);
                st.insert(d);
                iter = st.end();
                iter--;
                if(st.size() > k)
                    st.erase(iter);
            }
            else{
                iter = st.end();
                iter--;
                printf("%d\n", *iter);
            }
        }
    }
    return 0;
}

 还可以用vector;

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
vector<int>vec;
vector<int>::iterator iter;
int main(){
    int n, k;
    char s[2];
    while(~scanf("%d%d", &n, &k)){
        vec.clear();
        for(int i = 0; i < n; i++){
            scanf("%s", s);
            int v;
            if(s[0] == I){
                scanf("%d", &v);
                iter = lower_bound(vec.begin(), vec.end(), v);
                vec.insert(iter, v);
            }
            else{
                printf("%d\n", vec[vec.size() - k]);
            }
        }

    }
    return 0;
}

 

以上是关于The kth great number(set)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 4006 The kth great number

hdoj 4006 The kth great number(优先队列)

The kth great number_优先队列_priority

The kth great number multiset应用(找第k大值)

HDU 4006The kth great number(K大数 + 堆)

HDU 4006: The kth great number