2018山东省ACM省赛G题-Game
Posted lglh
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了2018山东省ACM省赛G题-Game相关的知识,希望对你有一定的参考价值。
To make this game even more interesting, they add a new rule: Bob can choose some piles and remove entire of them before the game starts. The number of removed piles is a nonnegative integer, and not greater than a given number d. Note d can be greater than n, and in that case you can remove all of the piles.
Let ans denote the different ways of removing piles such that Bob are able to win the game if both of the players play optimally. Bob wants you to calculate the remainder of ans divided by 10^9+7..
输入
For each test cases, the first line are two integers n and d, which are described above.
The second line are n positive integers ai, representing the number of stones in each pile.
T ≤ 5, n ≤ 10^3, d ≤ 10, ai ≤ 10^3
输出
样例输入
2
5 2
1 1 2 3 4
6 3
1 2 4 7 1 2
样例输出
2
5
根据数据大小,显然用DP,此处个人觉得最重要的是深刻异或的性质,然后写递推式就比较简单了!
AC代码:
#include <bits/stdc++.h>
using namespace std;
const int mod=1e9+7;
int dp[1003][12][1040],a[1234];
int main()
{
int t,sum,ans,n,d;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&d);
ans=0;
sum=0;
for(int i=1; i<=n; i++)
{
scanf("%d",&a[i]);
sum^=a[i];
}
dp[0][0][0]=1;
for(int i=1; i<=n; i++)
{
dp[i][0][0]=1;
for(int j=1; j<=d ; j++)
{
for(int k=0; k<=1204; k++)
{
dp[i][j][k]=dp[i-1][j][k]+dp[i-1][j-1][k^a[i]];
if(dp[i][j][k]>=mod)
{
dp[i][j][k]-=mod;
}
}
if(i==n)
{
ans+=dp[n][j][sum];
if(ans>=mod)
{
ans-=mod;
}
}
}
}
ans=(ans+dp[n][0][sum]);
printf("%d\n",ans);
}
return 0;
}
以上是关于2018山东省ACM省赛G题-Game的主要内容,如果未能解决你的问题,请参考以下文章