TOJ 3812Find the Lost Sock

Posted kannyi

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了TOJ 3812Find the Lost Sock相关的知识,希望对你有一定的参考价值。

描述

Alice bought a lot of pairs of socks yesterday. But when she went home, she found that she has lost one of them. Each sock has a name which contains exactly 7 charaters.

技术分享图片

Alice wants to know which sock she has lost. Maybe you can help her.

输入

There are multiple cases. The first line containing an integer n (1 <= n <= 1000000) indicates that Alice bought n pairs of socks. For the following 2*n-1 lines, each line is a string with 7 charaters indicating the name of the socks that Alice took back.

输出

The name of the lost sock.

样例输入

2
aabcdef
bzyxwvu
bzyxwvu
4
aqwerty
eas fgh
aqwerty
easdfgh
easdfgh
aqwerty
aqwerty
2
0x0abcd
0ABCDEF
0x0abcd

样例输出

aabcdef
eas fgh
0ABCDEF

提示

Because of HUGE input, scanf is recommended.

#include<bits/stdc++.h>
using namespace std;
char a[8],x[8],ch;
int main()
{
    int i,j,n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        getchar();
        for(i=1;i<=2*n-1;i++)
        {
            for(j=0;j<7;j++)
            {
                ch=getchar();
                x[j]=ch;
                a[j]^=x[j];
            }
            getchar();
        }    
        a[7]=\0;
        printf("%s\n",a);
    }
    return 0;
}

















以上是关于TOJ 3812Find the Lost Sock的主要内容,如果未能解决你的问题,请参考以下文章

TOJ 1210 The area(微积分)

TOJ-1321 The Brick Stops Here

TOJ 4475The Coolest Sub-matrix(对角线前缀和)

Connection lost: The server closed the connection

hihocoder#1094 : Lost in the City

The Lost House