POJ1456

Posted Peper

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ1456相关的知识,希望对你有一定的参考价值。

Supermarket
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15184   Accepted: 6851

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 
技术分享图片

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.
 
题目大意:给你一堆商品,每个商品有自己的价值和保质期(过了保质期后就不能卖了),每卖一件商品需要一天,求商家能获得的最大利润。
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct node{
	int w,t;
}sell[100007];
int fa[100007],n;
template<class T>void read(T &x)
{
	x=0;char ch=getchar();
	while(ch<‘0‘||ch>‘9‘)  ch=getchar();
	while(ch>=‘0‘&&ch<=‘9‘){x=(x<<1)+(x<<3)+(ch^48);ch=getchar();}
}
bool cmp(node x,node y)
{
	return x.w>y.w;
}
int find(int x)
{
	int p=x,q;
	while(fa[x]!=-1)
	  x=fa[x];
	while(p!=x)
	{
		q=fa[p];
		fa[p]=x;
		p=q;
	}
	return x;
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		int ans=0;
		memset(fa,-1,sizeof(fa));
		for(int i=1;i<=n;++i)
		{
			read(sell[i].w);
			read(sell[i].t);
		}
		sort(sell+1,sell+n+1,cmp);
		for(int i=1;i<=n;++i)
		{
			int q=find(sell[i].t);
			if(q>0)
		    {
		  		ans+=sell[i].w;
		  		fa[q]=q-1;
		  	}
		}
		printf("%d\n",ans);
	}
	return 0;
}

  

 



以上是关于POJ1456的主要内容,如果未能解决你的问题,请参考以下文章

poj1456Supermarket——并查集压缩查找

POJ-1456 Supermarket贪心+并查集

POJ 1456 贪心 并查集

[POJ1456]Supermarket(贪心 + 优先队列 || 并查集)

POJ1456:Supermarket(并查集+贪心)

POJ1456 Supermarket