nyoj Registration system
Posted tianzeng
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了nyoj Registration system相关的知识,希望对你有一定的参考价值。
Registration system
- 描述
-
A new e-mail service "Berlandesk" is going to be opened in Berland in the near future.
The site administration wants to launch their project as soon as possible, that‘s why they
ask you to help. You‘re suggested to implement the prototype of site registration system.
The system should work on the following principle.
Each time a new user wants to register, he sends to the system a request with his name.
If such a name does not exist in the system database, it is inserted into the database, and
the user gets the response OK, confirming the successful registration. If the name already
exists in the system database, the system makes up a new user name, sends it to the user
as a prompt and also inserts the prompt into the database. The new name is formed by the
following rule. Numbers, starting with 1, are appended one after another to name (name1,
name2, ...), among these numbers the least i is found so that namei does not yet exist in
the database.
- 输入
- The first line contains number n (1?≤?n?≤?105). The following n lines contain the requests to the system. Each request is a non-empty line, and consists of not more than 1000 characters, which are all lowercase Latin letters.
- 输出
- Print n lines, which are system responses to the requests: OK in case of successful registration, or a prompt with a new name, if the requested name is already taken.
- 样例输入
-
4 abacaba acaba abacaba acab
- 样例输出
-
OK OK abacaba1 OK
#include <iostream>
#include <map>
using namespace std;int main()
{
int n;
map<string,int> m;
cin>>n;
while(n--)
{
string s;
cin>>s;
if(m[s])
cout<<s<<m[s]<<endl;
else
cout<<"OK"<<endl;
m[s]++;
}
return 0;
}map:数据的插入
在构造map容器后,我们就可以往里面插入数据了。这里讲三种插入数据的方法:
第一种:用insert函数插入pair数据
map<int, string> mapStudent;
mapStudent.insert(pair<int, string>(1,“student_one”));第二种:用insert函数插入value_type数据
map<int, string> mapStudent;
mapStudent.insert(map<int, string>::value_type (1,"student_one"));mapStudent.insert(make_pair(1, "student_one"));
第三种:用数组方式插入数据map<int, string> mapStudent;
mapStudent[1] = “student_one”;
mapStudent[2] = “student_two”;/*如果是
#include <map>
map<string, int> mapStudent;string s;
插入就用m[s]++;*/以上三种用法,虽然都可以实现数据的插入,但是它们是有区别的,当然了第一种和第二种在效果上是完成一样的,用insert函数插入数据,在数据的插入上涉及到集合的唯一性这个概念,即当map中有这个关键字时,insert操作是不能再插入这个数据的,但是用数组方式就不同了,它可以覆盖以前该关键字对应的值,即:如果当前存在该关键字,则覆盖改关键字的值,否则,以改关键字新建一个key—value;
以上是关于nyoj Registration system的主要内容,如果未能解决你的问题,请参考以下文章
[翻译]Component Registration in Script System 在脚本系统中注册组件
C. Registration system1300 / 哈希