洛谷 P3128 [USACO15DEC]最大流Max Flow

Posted 一蓑烟雨任生平

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了洛谷 P3128 [USACO15DEC]最大流Max Flow相关的知识,希望对你有一定的参考价值。

题目描述

Farmer John has installed a new system of N-1N1 pipes to transport milk between the NN stalls in his barn ( 2 \leq N \leq 50,0002N50,000 ), conveniently numbered 1 \ldots N1N . Each pipe connects a pair of stalls, and all stalls are connected to each-other via paths of pipes.

FJ is pumping milk between KK pairs of stalls ( 1 \leq K \leq 100,0001K100,000 ). For the ii th such pair, you are told two stalls s_isi? and t_iti? , endpoints of a path along which milk is being pumped at a unit rate. FJ is concerned that some stalls might end up overwhelmed with all the milk being pumped through them, since a stall can serve as a waypoint along many of the KKpaths along which milk is being pumped. Please help him determine the maximum amount of milk being pumped through any stall. If milk is being pumped along a path from s_isi? to t_iti? , then it counts as being pumped through the endpoint stalls s_isi? and

t_iti? , as well as through every stall along the path between them.

FJ给他的牛棚的N(2≤N≤50,000)个隔间之间安装了N-1根管道,隔间编号从1到N。所有隔间都被管道连通了。

FJ有K(1≤K≤100,000)条运输牛奶的路线,第i条路线从隔间si运输到隔间ti。一条运输路线会给它的两个端点处的隔间以及中间途径的所有隔间带来一个单位的运输压力,你需要计算压力最大的隔间的压力是多少。

输入输出格式

输入格式:

 

The first line of the input contains NN and KK .

The next N-1N1 lines each contain two integers xx and yy ( x \ne yxy ) describing a pipe

between stalls xx and yy .

The next KK lines each contain two integers ss and tt describing the endpoint

stalls of a path through which milk is being pumped.

 

输出格式:

 

An integer specifying the maximum amount of milk pumped through any stall in the

barn.

 

输入输出样例

输入样例#1: 复制
5 10
3 4
1 5
4 2
5 4
5 4
5 4
3 5
4 3
4 3
1 3
3 5
5 4
1 5
3 4
输出样例#1: 复制
9
思路:lca和树上差分。
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 100000+15
using namespace std;
int n,k,tot,maxn=-1;
int to[MAXN*2],head[50001],net[MAXN*4],c[50001];
int deep[50001],size[50001],top[50001],dad[50001];
void add(int u,int v){
    to[++tot]=v;net[tot]=head[u];head[u]=tot;
    to[++tot]=u;net[tot]=head[v];head[v]=tot;
}
void dfs(int x){
    size[x]=1;
    deep[x]=deep[dad[x]]+1;
    for(int i=head[x];i;i=net[i])
        if(dad[x]!=to[i]){
            dad[to[i]]=x;
            dfs(to[i]);
            size[x]+=size[to[i]];
        }
}
void dfs1(int x){
    int t=0;
    if(!top[x])    top[x]=x;
    for(int i=head[x];i;i=net[i])
        if(dad[x]!=to[i]&&size[t]<size[to[i]])
            t=to[i];
    if(t){
        top[t]=top[x];
        dfs1(t);
    } 
    for(int i=head[x];i;i=net[i])
        if(dad[x]!=to[i]&&to[i]!=t)
            dfs1(to[i]);
}
int lca(int x,int y){
    for(;top[x]!=top[y];){
        if(deep[top[x]]<deep[top[y]])
            swap(x,y);
        x=dad[top[x]];
    }
    if(deep[x]>deep[y])
        swap(x,y);
    return x;
}
void dfs2(int x){
    for(int i=head[x];i;i=net[i])
        if(dad[x]!=to[i]){
            dfs2(to[i]);
            c[x]+=c[to[i]];
        }
    maxn=max(maxn,c[x]);
}
int main(){
    scanf("%d%d",&n,&k);
    for(int i=1;i<n;i++){
        int x,y;
        scanf("%d%d",&x,&y); 
        add(x,y);
    }
    dfs(1);
    dfs1(1);
    for(int i=1;i<=k;i++){
        int x,y;
        scanf("%d%d",&x,&y);
        int l=lca(x,y);
        c[x]++;c[y]++;
        c[l]--;c[dad[l]]--;
    }
    dfs2(1);
    cout<<maxn;
}
/*
5 10
3 4
1 5
4 2
5 4
5 4
5 4
3 5
4 3
4 3
1 3
3 5
5 4
1 5
3 4
*/
/*
Sunday‘s coming i wanna drive my car
周日就要到了,我想开车去你的公寓
to your apartment with a present like a star
带着晨星般的礼物
forecaster said the weather may be rainy hard
预报说那天将会下大雨
but i know the sun will shine for us
但是我知道太阳会为我们而闪耀
oh lazy seagull fly me from the dark
慵懒的海鸥带我飞出黑暗
i dress my jeans and feed my monkey banana
我穿上牛仔裤,喂猴子吃香蕉
then i think my age how old,skyline how far
然后想着,我有多大,地平线有多远
or we need each other in california
在加利福利亚州 我们彼此需要
you show me your body before night comes down
在夜幕降临前 你向我展现你的身姿
i touch your face and promise to stay ever young
我轻抚你的脸颊,承诺永远青春
on this ivory beach we kissed so long
在象牙色的海滩 我们久久拥吻
it seems that the passion‘s never gone
仿佛这份激情永不消逝
you sing me your melody and i feel so please
你为我唱出自己的旋律,我感到如此愉悦
i want you to want me to keep your dream
我渴望你也想要我守护你的梦想
together we‘ll run wild by a summer symphony
我们一起在夏日交响中 狂野的奔跑
this is what we enjoyed not a fantasy
这是我们的喜悦而非幻想
the tin-man‘s surfing i wanna try my luck
我想尝试冲浪
to the top of tide rip like just have some drugs
像服了兴奋剂般冲上浪尖
i know you have no blame for my proud moonish heart
我知道你对我骄傲易变的心 不会有任何责备
welcome to the golden beatnik park
欢迎来到比特尼克一代的黄金花园
oh diamond seashore drag me from the yard
钻石般的海岸将我拉离花园
incredible sunward i watch as you‘re in photograph
我难以置信的朝着太阳看你的照片
for camera your smile‘s so sweet,palm trees‘ so lush
镜头中,你的微笑这样的甜美,棕榈树这样的青葱
would you believe my honey it‘s califonia
你相信吗,我的甜心,这就是加利福利亚
you show me your body before night comes down
在夜幕降临前你向我展现你的身姿
i touch your face and promise to stay ever young
我轻抚你的脸颊,承诺永远青春
on this ivory beach we kissed so long
在象牙色的海滩我们久久拥吻
it seems that the passion‘s never gone
仿佛这份激情永不消逝
you sing me your melody and i feel so please
你为我唱出自己的旋律,我感到如此愉悦
i want you to want me to keep your dream
我渴望你也想要我守护你的梦想
together we‘ll run wild by a summer symphony
我们一起在夏日交响中狂野的奔跑
this is what we enjoyed not a fantasy
这是我们的喜悦而非幻想
*/

 

 

以上是关于洛谷 P3128 [USACO15DEC]最大流Max Flow的主要内容,如果未能解决你的问题,请参考以下文章

洛谷——P3128 [USACO15DEC]最大流Max Flow

洛谷P3128 [USACO15DEC]最大流Max Flow

洛谷 P3128 [USACO15DEC]最大流Max Flow

AC日记——[USACO15DEC]最大流Max Flow 洛谷 P3128

洛谷P3128 [USACO15DEC]最大流Max Flow [倍增LCA]

P3128 [USACO15DEC]最大流Max Flow