Super Jumping! Jumping! Jumping!

Posted SDAU_ZG

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Super Jumping! Jumping! Jumping!相关的知识,希望对你有一定的参考价值。

Super Jumping! Jumping! Jumping!

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 6   Accepted Submission(s) : 5

Font:   Times New Roman   |   Verdana   |   Georgia

Font Size:   ←   →

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 

技术分享


The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
Your task is to output the maximum value according to the given chessmen list. 

 

Input

Input contains multiple test cases. Each test case is described in a line as follow: 
N value_1 value_2 …value_N   
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case. 

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

题意:此题就是找序列中最大升序子序列的和。
比如  1 3 2 中升序序列有:{1}{3}{2}{1,3}{1,2}。所以最大为1+3=4;
定义两个数组:num[i]存i位置的数,sum[i]存i位置的最大和。
状态方程: sum[i]=max   {  sum[j](if(num[j]<num[i])) }  +  num[i]  ,  其中j<i。
代码注意处理下dp[0]就行。
代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn=1002;
int num[maxn];
int sum[maxn];
int n;

int main()
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        sum[1]=num[1];
        int ans=sum[1];
        for(int i=2;i<=n;i++)
        {
            sum[i]=num[i];
            for(int j=1;j<i;j++)
            {
                if(num[j]<num[i]&&sum[j]+num[i]>sum[i])//满足递增且当前的sum[i]小前面中的sum[j]+当前的数
                    sum[i]=sum[j]+num[i];//sum[i]为最长递增子序列的和,当前num[i]必选。
            }
            if(ans<sum[i])
                ans=sum[i];
        }
        printf("%d\n",ans);

    }
    return 0;
}

以上是关于Super Jumping! Jumping! Jumping!的主要内容,如果未能解决你的问题,请参考以下文章

[2016-03-27][HDU][1087][Super Jumping! Jumping! Jumping!]

Super Jupmping ! Jumping ! Jumping

HDU-1087.Super Jumping! Jumping! Jumping!

hdu 1087 Super Jumping! Jumping! Jumping! (dp最大递增字段和)

HDu1087 Super Jumping! Jumping! Jumping!

Super Jumping! Jumping! Jumping! HDU - 1087