Uva10340(字符串搜索)
Posted Western_Trail
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Uva10340(字符串搜索)相关的知识,希望对你有一定的参考价值。
You have devised a new encryption technique which encodes a message by inserting between its characters
randomly generated strings in a clever way. Because of pending patent issues we will not discuss in
detail how the strings are generated and inserted into the original message. To validate your method,
however, it is necessary to write a program that checks if the message is really encoded in the final
string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove
characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII
characters separated by whitespace. Input is terminated by EOF.
Output
For each test case output, if s is a subsequence of t.
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No
题意:
给出两个字符串s和t,判断是否可以从t中删除0个或者多个字符得到字符串s。
分析:
这里给出两种不同的做法。第二种做法可能更容易想到
1
/*将t中的每一个字符枚举过去与s的第一个字符比较
如果比较成功了,就开始比较s中的第二个字符,
以此类推*/
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
char s[100000];
char t[100000];
int main(){
while((scanf("%s",s)&&scanf("%s",t))!=EOF){
int star = 0,lens = strlen(s),lent = strlen(t);
for(int i = 0;i < lent;i++){
if(t[i] == s[star]){
star++;
}
if(star == lens){
printf("Yes\n");
break;
}
}
if(star != lens)
printf("No\n");
}
return 0;
}
2
#include <iostream>
#include <cstdio>
#include <cstring>
#define N 100010
using namespace std;
char str1[N], str2[N];
int s[N];
int main() {
while ((scanf("%s", str1) &&scanf("%s", str2))!= EOF) {
int m = 0; //保存相同字符的个数
int len1 = strlen(str1);
int len2 = strlen(str2);
memset(s, 0, sizeof(s));
if (len1 > len2)
printf("No\n");
else {
int k = 0;
for (int i = 0; i < len1; i++) {
for (int j = k; j < len2; j++) {
if (str1[i] == str2[j]) {
m++;
k = j + 1;
break;
}
}
}
if (m == len1)
printf("Yes\n");
else
printf("No\n");
}
}
return 0;
}
以上是关于Uva10340(字符串搜索)的主要内容,如果未能解决你的问题,请参考以下文章