ACM题目————Anagram

Posted Asimple

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了ACM题目————Anagram相关的知识,希望对你有一定的参考价值。

Description

You are to write a program that has to generate all possible words from a given set of letters.
Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.

Input

The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.

Output

For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.

Sample Input

3
aAb
abc
acba

Sample Output

Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa

Hint

An upper case letter goes before the corresponding lower case letter.
So the right order of letters is ‘A‘<‘a‘<‘B‘<‘b‘<...<‘Z‘<‘z‘.
 
STL的全排列问题,写好排序方案,直接调用 next_permutation()函数便可!
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>

using namespace std;

int n;
char str[15];

bool cmp(char a,char b)
{
    if(tolower(a)==tolower(b))
        return a<b;
    else
        return tolower(a)<tolower(b);
}

int main()
{
    scanf("%d",&T);
    while( T-- )
    {
        scanf("%s",str);
        sort(str,str+strlen(str),cmp);//自定义排序
        do
        {
            cout << str << endl ;
        }while(next_permutation(str,str+strlen(str),cmp));
    }

    return 0;
}

 

 

以上是关于ACM题目————Anagram的主要内容,如果未能解决你的问题,请参考以下文章

LeetcodeValid Anagram

Anagram

17.Valid Anagram

[leetcode]242.Valid Anagram

leetcode_1 Valid Anagram

[LeetCode] 242. Valid Anagram Java