Repair the Wall

Posted TCMのBLOG

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Repair the Wall相关的知识,希望对你有一定的参考价值。

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty‘s walls were made of wood.

One day, Kitty found that there was a crack in the wall. The shape of the crack is
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?

InputThe problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The i th integer Ai(0<Ai<1000000000 ) means that the i th block has the size of 1×Ai (in inch).
OutputFor each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.
Sample Input
5 3
3 2 1
5 2
2 1
Sample Output
2
impossible

一直以为要正好凑成那个长度,想了好久,唉。。。
敲代码之前先把题意看明白吧!
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cstring>
#include<math.h>
#include<algorithm>
#define ll long long int
using namespace std;

bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int len,n;
    while(scanf("%d%d",&len,&n)!=EOF)
    {
        int i,a=0,ans=0;
        int s[650]= {0};
        for(i=0; i<n; i++)
        {
            scanf("%d",&s[i]);
        }
        sort(s,s+n,cmp);
        for(i=0; i<n; i++)
        {
            a+=s[i];
            ans++;
            if(a>=len)
                break; 
        }
        if(i==n)
            printf("impossible\n");
        else
            printf("%d\n",ans);
    }
}

 

以上是关于Repair the Wall的主要内容,如果未能解决你的问题,请参考以下文章

HDU2124 Repair the Wall(贪心)

Repair the Wall

简单贪心) Repair the Wall hdu2124

hdu_2124 Flying to the Mars & hdu_1800 Repair the Wall 贪心水题

POJ3691DNA repair(AC自动机,DP)

UVA1045 The Great Wall Game