BZOJ1930: [Shoi2003]pacman 吃豆豆

Posted mt-li

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了BZOJ1930: [Shoi2003]pacman 吃豆豆相关的知识,希望对你有一定的参考价值。

Description

两个PACMAN吃豆豆。一开始的时候,PACMAN都在坐标原点的左下方,豆豆都在右上方。PACMAN走到豆豆处就会吃掉它。PACMAN行走的路线很奇怪,只能向右走或者向上走,他们行走的路线不可以相交。 请你帮这两个PACMAN计算一下,他们俩加起来最多能吃掉多少豆豆。

Input

第一行为一个整数N,表示豆豆的数目。 接下来 N 行,每行一对正整数,表示第i个豆豆的坐标。任意两个豆豆的坐标都不会重合。

Output

仅有一行包含一个整数,即两个PACMAN加起来最多能吃掉的豆豆数量

Sample Input

8

8 1

1 5

5 7

2 2

7 8

4 6

3 3

6 4

Sample Output

7

HINT

技术分享图片 

N < = 2000

 
 
刚开始想了半天不会做,硬是没算法??
然后推半天推了一个费用流,我想着不会这么巧吧·,看了看路牌,还真是!
那就做做吧。。。
首先最开始的建图我就想了会:
ST------>S   2 0
S-------->i    1 0
i--------->i+n 1 1
i+n-------->T 1 0
T----------->2 0
然后对于每对能互相搞得东西连边。。。
然后这题丧心病狂又卡空间又卡时间
那就优化啊。。。。
很棘手啊,缩边吧
有点像floyd??如果1能到2,2能到3,那么1,3就不用搞了
然后因为这样,我们又得改一下建图,因为你的流量限制了它不能在跑过去
 
代码如下:
#include<cmath>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
struct node{
    int x,y,c,d,next,other;
}a[2100000];int len,last[410000];
const int INF=99999999;
void ins(int x,int y,int c,int d)
{
    int k1,k2;
    k1=++len;
    a[len].x=x;a[len].y=y;a[len].c=c;a[len].d=d;
    a[len].next=last[x];last[x]=len;
    
    k2=++len;
    a[len].x=y;a[len].y=x;a[len].c=0;a[len].d=-d;
    a[len].next=last[y];last[y]=len;
    
    a[k1].other=k2;
    a[k2].other=k1;
}
int st,ed;
int head,tail,list[41000];
int pre[41000],cc[41000],d[41000];
bool v[41000];
int ans,flow;
bool spfa()
{
    for(int i=1;i<=ed+2;i++)d[i]=-1;
    d[st]=0;
    memset(cc,0,sizeof(cc));cc[st]=9999999;
    memset(v,false,sizeof(v));v[st]=true;
    list[1]=st;head=1;tail=2;
    while(head!=tail)
    {
        int x=list[head];
        for(int k=last[x];k;k=a[k].next)
        {
            int y=a[k].y;
            if(d[y]<d[x]+a[k].d&&a[k].c>0)
            {
                d[y]=d[x]+a[k].d;
                cc[y]=min(cc[x],a[k].c);
                pre[y]=k;
                if(v[y]==false)
                {
                    v[y]=true;
                    list[tail++]=y;
                    if(tail==ed+1)tail=1;
                }
            }
        }
        v[x]=false;
        head++;if(head==ed+1)head=1;
    }
    if(d[ed]==-1)return false;
    ans+=cc[ed]*d[ed];flow+=cc[ed];
    int x=ed;
    while(x!=0)
    {
        int k=pre[x];
        a[k].c-=cc[ed],a[a[k].other].c+=cc[ed];
        x=a[k].x;
    }
    return true;
}
struct zuobiao{
    int x,y;
}e[210000];
int n;
bool cmp(zuobiao a,zuobiao b)
{
    if(a.x!=b.x)return a.x<b.x;
    return a.y<b.y;
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)scanf("%d%d",&e[i].x,&e[i].y);
    len=0;memset(last,0,sizeof(last));
    st=2*n+1,ed=2*n+2;
    int S=ed+1,T=S+1;
    ins(st,S,2,0);ins(T,ed,2,0);
    for(int i=1;i<=n;i++)ins(S,i,1,0),ins(i+n,T,1,0),ins(i,i+n,1,1),ins(i,i+n,1,0);
    sort(e+1,e+1+n,cmp);
    for(int i=1;i<=n;i++)
    {
        int x=0;
        for(int j=i-1;j>=1;j--)
            if(e[i].y>=e[j].y&&e[j].y>x)
                x=e[j].y,ins(j+n,i,2,0);
    }
    ans=0;
    while(spfa()==true){}
    printf("%d\n",ans);
    return 0;
}

by_lmy

以上是关于BZOJ1930: [Shoi2003]pacman 吃豆豆的主要内容,如果未能解决你的问题,请参考以下文章

[bzoj1930] [Shoi2003]pacman 吃豆豆

BZOJ 1930 [Shoi2003]pacman 吃豆豆 最大费用最大流

bzoj1930

BZOJ 1022: [SHOI2008]小约翰的游戏John (Anti-nim)

BZOJ 1019: [SHOI2008]汉诺塔

P4066 [SHOI2003]吃豆豆