D - An easy problem

Posted 神韵袖藏

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了D - An easy problem相关的知识,希望对你有一定的参考价值。

We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
  We can define sum(n) as follow:
  if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
  Is it very easy ? Please begin to program to AC it..-_-

Input  The input file contains multilple cases.
  Every cases contain only ont line, every line contains a integer n (n<=100000).
  when n is a negative indicate the end of file.Output  output the result sum(n).
Sample Input

1
2
3
-1

Sample Output

1
3
30

刚开始看题里面用递归!就用了递归发现超内存了。于是就打表了。注意了,下次可以吸取这次的经验。
#include<iostream>
using namespace std;
#define N 100002
int main()
{
long long num[N],i;
num[0] = 0;
for ( i = 1; i < N; i++)
{
if (i % 3) num[i]=num[i - 1] + i;
else num[i]=num[i - 1] + i*i*i;
}
int n;
while (cin >> n)
{
if (n < 0) break;
cout << num[n] << endl;
}
return 0;
}


以上是关于D - An easy problem的主要内容,如果未能解决你的问题,请参考以下文章

An easy problem(hdu2055)

poj2826 An Easy Problem?!

ACM 2015年上海区域赛A题 HDU 5572An Easy Physics Problem

POJ 2826 An Easy Problem? 判断线段相交

An easy problem

an easy problem(贪心)