hdu 1013 Digital Roots

Posted 行尸走肉

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1013 Digital Roots相关的知识,希望对你有一定的参考价值。

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 68194    Accepted Submission(s): 21324


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

 

Sample Input
24 39 0
 

 

Sample Output
6 3
 

 

Source
 
考虑数字的位数很多,所以用数组。
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    char  n [1000];
    while(scanf("%s",n)&&n[0]!=\'0\')
    {
        int t=0;
        for(int i=0;i<strlen(n);i++)
            t+=n[i]-\'0\';
        long long  tmp=t;
        long long  ans=0;
        while(1)
        {
            while(tmp>0)
            {
                ans+=tmp%10;
                tmp/=10;
            }
            if(ans<10) break;
            tmp=ans;
            ans=0;
        }
        printf("%I64d\\n",ans);
    }
}
View Code

 

以上是关于hdu 1013 Digital Roots的主要内容,如果未能解决你的问题,请参考以下文章

hdu-1013 Digital Roots

Hdu 1013 Digital Roots

HDU 1013 Digital Roots(两种方法,求数字根)

解题报告:hdu1013 Digital Roots

hdu1013 Digital Roots

HDU 1013.Digital Roots模拟或数论8月16