1053. Path of Equal Weight (30)

Posted Dyleaf

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1053. Path of Equal Weight (30)相关的知识,希望对你有一定的参考价值。

1053. Path of Equal Weight (30)

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let‘s consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.

技术分享图片
Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID‘s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ... k, and Ak+1 > Bk+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题目大意:给出树的结构和权值,找从根结点到叶子结点的路径上的权值相加之和等于给定目标数的路径,并且从大到小输出路径

分析:对于接收孩子结点的数据时,每次完全接收完就对孩子结点按照权值进行排序(序号变,根据权值变),这样保证深度优先遍历的时候直接输出就能输出从大到小的顺序。

#include <bits/stdc++.h>
using namespace std;
struct NODE{
    int value,id;
    vector<NODE>son;
};
vector<NODE> v;
int s;
int path[1000];
void dfs(int id, int w, int cnt){
    if(w == s && v[id].son.size() ==0){
        printf("%d", v[path[0]].value);
        for(int i=1; i<cnt; i++){
            printf(" %d", v[path[i]].value);
        }
        printf("\n");
        return;
    }
    for(int i=0; i<v[id].son.size(); i++){
        if( w + v[id].son[i].value <= s){
            path[cnt] = v[id].son[i].id;
            dfs(v[id].son[i].id, w+v[id].son[i].value, cnt+1);
        }
    }
}

bool cmp(NODE a, NODE b){
    return a.value > b.value;
}

int main(){
    int n, m;
    scanf("%d%d%d", &n, &m,&s);
    v.resize(n);
    for(int i=0; i<n; i++){
        scanf("%d", &v[i].value);
        v[i].id = i;
    }
    for(int i = 0; i<m; i++){
        int id, num;
        scanf("%d%d", &id, &num);
        int value;
        for(int j = 0; j<num; j++){
            scanf("%d", &value);
            v[id].son.push_back(v[value]);
        }
        sort(v[id].son.begin(), v[id].son.end(), cmp);
    }
    path[0] = 0;
    dfs(0,v[0].value,1);
}

以上是关于1053. Path of Equal Weight (30)的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1053. Path of Equal Weight

PAT 1053 Path of Equal Weight (30)

1053 Path of Equal Weight

1053 Path of Equal Weight

PAT 1053. Path of Equal Weight (30)

PAT Advanced Level 1053 Path of Equal Weight