TOJ2712: Atlantis

Posted BobHuang

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了TOJ2712: Atlantis相关的知识,希望对你有一定的参考价值。

小数据求面积并

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.

Sample Input

 

2
10 10 20 20
15 15 25 25.5
0

Sample Output

 

Test case #1
Total explored area: 180.00

Source

Mid-Central Europe 2000

这个直接用了二分查询,但是复杂度还是蛮高的

 

#include<bits/stdc++.h>
using namespace std;
const int N=205;
const double eps=1e-8;
int n,vis[N],t;
double has[N];
struct line
{
    double l,r,y;
    int f;
    line(){}
    line(double l,double r,double y,int f):l(l),r(r),y(y),f(f){}
}L[N];
bool cmp(line a,line b)
{
    return a.y<b.y;
}
int get(double x)
{
    return lower_bound(has,has+t,x)-has;
}
int main()
{
    int ca=0,i,j;
    double x1,y1,x2,y2;
    while(scanf("%d",&n),n)
    {
        t=0;
        memset(vis,0,sizeof vis);
        for(i=0; i<n; i++)
        {
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            L[t]=line(x1,x2,y1,1),has[t++]=x1;
            L[t]=line(x1,x2,y2,-1),has[t++]=x2;
        }
        n*=2;
        sort(L,L+n,cmp);
        sort(has,has+t);
        t=1;
        for(i=1;i<n;i++)
            if(fabs(has[i]-has[i-1])>eps)has[t++]=has[i];
        double res=0;
        for(i=0; i<n; i++)
        {
            int l=get(L[i].l),r=get(L[i].r);
            double len=0;
            for(j=0;j<t-1;j++)
                if(vis[j]>0)len+=has[j+1]-has[j];
            if(i)res+=len*(L[i].y-L[i-1].y);
             for(j=l;j<r;j++)vis[j]+=L[i].f;
        }
        printf("Test case #%d\nTotal explored area: %.2f\n\n",++ca,res);
    }
    return 0;
}

 

 

 

以上是关于TOJ2712: Atlantis的主要内容,如果未能解决你的问题,请参考以下文章

hdu1542 Atlantis(扫描线+线段树+离散)矩形相交面积

hdu 1542/1255 Atlantis/覆盖的面积

HDU1542--Atlantis(扫描线)

poj1151 Atlantis (线段树+扫描线+离散化)

带有顶点/片段着色器的光。使用不同的变量。 (openGL)

TOJ 5347: 数据结构实验:删除链表元素