2456. mode乱搞

Posted Refun

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了2456. mode乱搞相关的知识,希望对你有一定的参考价值。

Description

给你一个n个数的数列,其中某个数出现了超过n div 2次即众数,请你找出那个数。

Input

第1行一个正整数n。
第2行n个正整数用空格隔开。

Output

    一行一个正整数表示那个众数。

Sample Input

5
3 2 3 1 3

Sample Output

3

HINT

100%的数据,n<=500000,数列中每个数<=maxlongint。

 

因为众数要超过一半,所以我们让两个不相同的数相互抵消,最后剩下的就是众数了

 

#include<cstdio>
using namespace std;
int n,cnt,x,num;
int main()
{
	scanf("%d",&n);
	for (int i=1;i<=n;++i)
	{
		scanf("%d",&x);
		if (cnt==0)
		{
			cnt++;
			num=x;
		}
		else
		if (x!=num)
			cnt--;
		else
			cnt++;
	}
	printf("%d",num);
}

 

以上是关于2456. mode乱搞的主要内容,如果未能解决你的问题,请参考以下文章

BZOJ2456: mode(trick乱搞QWQ)

bzoj2456: mode

bzoj 2456 mode

2456: mode

[bzoj 2456]mode

Bzoj 2456: mode 数论,众数