HDU1108 最小公倍数

Posted eric1563901725

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1108 最小公倍数相关的知识,希望对你有一定的参考价值。

最小公倍数

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 65262    Accepted Submission(s): 35910


Problem Description
给定两个正整数,计算这两个数的最小公倍数。
 

 

Input
输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.
 

 

Output
对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。
 

 

Sample Input
10 14
 

 

Sample Output
70
 
 
题解:没什么技巧,直接遍历就行。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

int main()
{
    long a,b,c;
    long i;
    while(scanf("%ld%ld",&a,&b) != EOF)
    {
        for(i = 1;i <= b;i++)
        {
            if((a * i) % b == 0)
            {
                c = a * i;
                break;
            }
        }
        printf("%ld\n",c);
    }
    return 0;
}

 

 

以上是关于HDU1108 最小公倍数的主要内容,如果未能解决你的问题,请参考以下文章

HDU1108 最小公倍数

HDU 1108: 最小公倍数

最小公倍数hdu1108

hdu_1108 最小公倍数

HDU 1108: 最小公倍数(in Java)

HDU 1108