1085. Perfect Sequence (25)

Posted 王清河

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1085. Perfect Sequence (25)相关的知识,希望对你有一定的参考价值。

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8
#include<cstdio>                                    
#include<algorithm>                                 
using namespace std;                                
int n,p,a[100010];                                  
                                                    
int binarySearch(int i, long long x){               
    if(a[n - 1] <= x) return n;                        
    int l = i + 1, r = n - 1;                          
    while(l < r){                                      
        int mid = (r + l) / 2;                            
        if(a[mid] <= x){                                  
            l = mid + 1;                                     
        }else{                                            
            r = mid;                                         
        }                                                 
    }                                                  
    return l;                                          
}                                                   
                                                    
int main(){                                         
                                                       
    scanf("%d%d",&n,&p);                               
    for(int i = 0; i < n; i++){                        
        scanf("%d",&a[i]);                                
    }                                                  
    sort(a,a+n);                                       
    int ans = 1;                                       
    for(int i = 0; i < n; i++){                        
                                                          
        int j = binarySearch(i,(long long)a[i]*p);        
        ans = max(ans, j - i);                            
    }                                                  
    printf("%d\n",ans);                                
    return 0;                                          
}                                                   

 

以上是关于1085. Perfect Sequence (25)的主要内容,如果未能解决你的问题,请参考以下文章

1085. Perfect Sequence (25)

1085. Perfect Sequence (25)

1085 Perfect Sequence (25 分)

1085 Perfect Sequence (25分)

1085. Perfect Sequence (25)-PAT甲级真题

1085. Perfect Sequence (25)-水题