1050. String Subtraction (20)

Posted 王清河

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1050. String Subtraction (20)相关的知识,希望对你有一定的参考价值。

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.
#include<cstdio>
#include<cstring>
const int maxn = 10010;
char a[maxn],b[maxn];
bool hashTable[128] = {false};
int main(){
    gets(a);
    gets(b);
    int len1 = strlen(a);
    int len2 = strlen(b);
    for(int i = 0; i < len2; i++){
        hashTable[b[i]] = true;
    }
    for(int i = 0; i < len1; i++){
        if(hashTable[a[i]] == false){
            printf("%c",a[i]);
        }
    }
    return 0;
}

 

以上是关于1050. String Subtraction (20)的主要内容,如果未能解决你的问题,请参考以下文章

1050 String Subtraction (20 分)

PAT1050 : String Subtraction

1050. String Subtraction (20)

1050 String Subtraction (20 分)哈希 map

pat 1050 String Subtraction(20 分)

1050 String Subtraction