L2-008. 最长对称子串

Posted Pretty9

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了L2-008. 最长对称子串相关的知识,希望对你有一定的参考价值。

对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定"Is PAT&TAP symmetric?",最长对称子串为"s PAT&TAP s",于是你应该输出11。

输入格式:

输入在一行中给出长度不超过1000的非空字符串。

输出格式:

在一行中输出最长对称子串的长度。

输入样例:

Is PAT&TAP symmetric?

输出样例:

11
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<vector>
#include<set>
#include<queue>
#include<string>
using namespace std;

int main(){
    string str;

    getline(cin, str);
    int len = str.length();
    int maxi = 1;
    for(int i = 1; i < len - 1; i++){
        int cnt = 1, head = i - 1, tail = i + 1;
        while(head >= 0 && tail < len && str[head] == str[tail]){
            cnt += 2;
            head--; tail++;
        }
        maxi = max(maxi, cnt);
        cnt = 0, head = i - 1, tail = i;
        while(head >= 0 && tail < len && str[head] == str[tail]){
            cnt += 2;
            head--; tail++;
        }
        maxi = max(maxi, cnt);
    }
    cout << maxi << endl;
}

 

以上是关于L2-008. 最长对称子串的主要内容,如果未能解决你的问题,请参考以下文章

L2-008. 最长对称子串

L2-008 最长对称子串 (25分)

L2-008 最长对称子串 (25 分) (模拟)

天梯杯 L2-008. 最长对称子串(马拉车算法应用)

L2-008 最长对称子串(马拉车 or 技巧暴力)

C语言L2-008 最长对称子串 (25分)简单解法/附带思路