LightOJ 1214(Large Division)

Posted ACRykl

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了LightOJ 1214(Large Division)相关的知识,希望对你有一定的参考价值。

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.


Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print ‘divisible‘ if a is divisible by b. Otherwise print ‘not divisible‘.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

 

分析:大数取余。

技术分享图片
#include<cstdio>
char s[300];
int main()
{
    int T,cas=0;long long b;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%lld",s,&b);
        if(b<0) b=-b;
        int i=0;
        if(s[i]==-) i++;
        long long res=0;
        while(s[i])
            res=(res*10+(s[i++]-0))%b;
        if(res==0) printf("Case %d: divisible\n",++cas);
        else printf("Case %d: not divisible\n",++cas);
    }
    return 0;
}
View Code

 

 

 

 


以上是关于LightOJ 1214(Large Division)的主要内容,如果未能解决你的问题,请参考以下文章

LightOJ1214 Large Division 基础数论+同余定理

大数模拟——K - Large Division LightOJ - 1214

1214 - Large Division -- LightOj(大数取余)

Light oj 1214-Large Division (同余定理)

light oj 1214 - Large Division 大数除法

light oj 1214 Large Division