LightOJ 1341(Aladdin and the Flying Carpet )算术基本定理

Posted ACRykl

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了LightOJ 1341(Aladdin and the Flying Carpet )算术基本定理相关的知识,希望对你有一定的参考价值。

It‘s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin‘s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.


Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

 

分析:给出整数a和b,求区间[b, a] 内的 a 的约数对的个数,

满足c*d == a 且 c,d>=b且c!=d。a 的约数对(比如[2, 3] 与 [3, 2] 为同一对)。

PS:

 

先素数打表一下,然后再运用算术基本定理中的(1)

 

技术分享图片

 

即可求出正因数的个数,然后再除以2,便是对数,

最后再暴力求解出[1,b]中 a 的正因数个数,相减便是答案!

技术分享图片
#include<cstdio>
#include<cmath>
bool a[1000090];
int p[100090],cnt=1;
void prime()
{
    for(int i=4;i<1000001;i+=2) a[i]=1;
    p[0]=2;
    for(int i=3;i<1000001;i++)
    {
        if(!a[i])
        {
            p[cnt++]=i;
            for(int j=i+i;j<1000001;j+=i)
            a[j]=1;
        }
    }
}

long long f(long long N)
{
    long long ans=1;
    long long K=sqrt(N*1.0);
    for(int i=0;p[i]<=N&&i<cnt;i++)
    {
        int temp=1;
        while(N%p[i]==0)
        {
            temp++;
            N/=p[i];
        }
        ans*=temp;
    }
    if(N>1) ans*=2;//即N未除尽
    return ans/2;
}

int main()
{
    int T,cas=1;
    long long N,b;
    scanf("%d",&T);
    prime();
    while(T--)
    {
        scanf("%lld%lld",&N,&b);
        if(b*b>N) printf("Case %d: 0\n",cas++);
        else
        {
            int res=0;
            for(int i=1;i<b;i++)//1~b
                if(N%i==0) res++;
            printf("Case %d: %lld\n",cas++,f(N)-res);
        }
    }
    return 0;
}
View Code

 

 

 


以上是关于LightOJ 1341(Aladdin and the Flying Carpet )算术基本定理的主要内容,如果未能解决你的问题,请参考以下文章

[LightOJ 1341] Aladdin and the Flying Carpet (算数基本定理(唯一分解定理))

LightOJ1341 Aladdin and the Flying Carpet

LightOJ 1341 Aladdin and the Flying Carpet(唯一分解定理)

Aladdin and the Flying Carpet (LightOJ - 1341)简单数论算术基本定理分解质因数(未完成)

LightOJ1341 Aladdin and the Flying Carpet 约数相关问题

LightOJ-1341 Aladdin and the Flying Carpet 分解质因数(注意对大素数的优化)