nyoj248 BUYING FEED(贪心orDP)

Posted 甄情

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了nyoj248 BUYING FEED(贪心orDP)相关的知识,希望对你有一定的参考价值。

BUYING FEED

时间限制:3000 ms  |  内存限制:65535 KB
难度:4
描述

Farmer John needs to travel to town to pick up K (1 <= K <= 100)pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

The county feed lot has N (1 <= N<= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell John as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound.
Amazingly, a given point on  the X axis might have more than one store.

Farmer John  starts  at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores along the way and buy any amount of feed up to the the store‘s limit.  What is the minimum amount Farmer John has to pay to buy and transport the K pounds of feed? Farmer John
knows there is a solution.
Consider a sample where Farmer John  needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:     
0   1   2  3   4   5
    
---------------------------------
         
1       1   1                Available pounds of feed
         
1       2   2               Cents per pound

It is best for John to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When John travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay1*1 = 1 cents.

When John travels from 4 to 5 heis moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.

输入
The first line of input contains a number c giving the number of cases that follow
There are multi test cases ending with EOF.
Each case starts with a line containing three space-separated integers: K, E, and N
Then N lines follow :every line contains three space-separated integers: Xi Fi Ci
输出
For each case,Output A single integer that is the minimum cost for FJ to buy and transport the feed
样例输入
1
2 5 3                 
3 1 2
4 1 2
1 1 1
样例输出
7
来源
第三届河南省程序设计大赛
上传者

ACM_赵铭浩

今天上午做的时候  因为先入为主的思想  认为这道题就是DP  一直浪费了好多时间  知道下午 听到说贪心可以做

一下子就做出来了  还是太年轻。。。上午也不是没有想贪心 只是想得太浅  没细想

贪心A了以后  因为我感觉 我上午想的没错  看了评论区 才知道 可能会有多个商店在同一点上 。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。我吐血了。。

也算用DP做了

贪心方法:

单价+某点到终点的距离  从小到大排序即可

所买的 肯定是最便宜的。

代码:

 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
	int x;
	int w;
	int per;
}c[400];
int n,e,k;
bool cmp(node a,node b)
{
	return n-a.x+a.per<n-b.x+b.per;
}
int main()
{
	int ncase;
	scanf("%d",&ncase);
	while(ncase--)
	{
		memset(&c,0,sizeof(&c));
		scanf("%d %d %d",&k,&e,&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d %d %d",&c[i].x,&c[i].w,&c[i].per);
		}
		sort(c,c+n,cmp);
		int cost=0;
		for(int i=0;i<n;i++)
		{
			if(k>=c[i].w)
			{
				cost+=(e-c[i].x)*c[i].w+c[i].w*c[i].per;
				k-=c[i].w;
			}
			else
			{
				cost+=(e-c[i].x)*k+k*c[i].per;
				k=0;
			}
			if(k==0)
			break;
		}
		printf("%d\n",cost);
	}
	return 0;
}         

  DP 思想:

dp[x][w]  其中x为当前坐标 w为已购买的数量

for i=0.....FI

dp[x][w]=min(dp[x][w],dp[x-1][w-i]+i*Ci+(e-x+1)*i);

AC代码:

 
#include <stdio.h>
#include <vector>
#include <algorithm>
#include <string.h>
using namespace std;
struct node
{
	int w;
	int per;
};
int main()
{
	int k,e,n;
	int dp[400][105];
	int ncase;
	vector<node>edge[400];
	scanf("%d",&ncase);
	while(ncase--)
	{
		memset(dp,100,sizeof(dp));
		memset(edge,0,sizeof(edge));
		scanf("%d %d %d",&k,&e,&n);
		for(int i=0;i<n;i++)
		{
			int xi;
			node temp;
			scanf("%d %d %d",&xi,&temp.w,&temp.per);
			edge[xi].push_back(temp);
		}
		dp[0][0]=0;
		for(int i=1;i<=e;i++)
		{
			for(int l=k;l>=0;l--)
			{
				dp[i][l]=dp[i-1][l];
				for(int j=0;j<edge[i-1].size();j++)
				{
					int Per=edge[i-1][j].per;
					int W=edge[i-1][j].w;
					for(int p=0;p<=W;p++)
					if(l>=p)
					dp[i][l]=min(dp[i][l],dp[i-1][l-p]+p*Per+(e-i+1)*p);
				}
			}
		}
		printf("%d\n",dp[e][k]);
	}
	return 0; 
}                


以上是关于nyoj248 BUYING FEED(贪心orDP)的主要内容,如果未能解决你的问题,请参考以下文章

P4544 [USACO10NOV]购买饲料Buying Feed

Buying Feed, 2010 Nov (单调队列优化DP)

A. Buying Torches1000 / 贪心

洛谷P2983 [USACO10FEB]购买巧克力Chocolate Buying(贪心)

[CF1136D] Nastya Is Buying Lunch - 贪心

CF1136D Nastya Is Buying Lunch 贪心