UVA - 536 Tree Recovery

Posted llguanli

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA - 536 Tree Recovery相关的知识,希望对你有一定的参考价值。

Description

技术分享图片


? Tree Recovery?

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

                                    D
                                   /                                   /                                    B     E
                                / \                                    /   \     \ 
                              A     C     G
                                         /
                                        /
                                       F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).


Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input Specification?

The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output Specification?

For each test case, recover Valentine‘s binary tree and print one line containing the tree‘s postorder traversal (left subtree, right subtree, root).

Sample Input?

DBACEGF ABCDEFG
BCAD CBAD

Sample Output?

ACBFGED
CDAB

题意:给出二叉树前中序,求后序

思路:水题

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXN = 50;

void build(int len, char pre[], char in[], char post[]) {
	if (len <= 0)
		return;
	int cur = strchr(in, pre[0]) - in;
	build(cur, pre+1, in, post);
	build(len-1-cur, pre+cur+1, in+cur+1, post+cur);
	post[len-1] = pre[0];
}

int main() {
	char preOrd[MAXN], inOrd[MAXN], postOrd[MAXN];
	while (scanf("%s%s", preOrd, inOrd) != EOF) {
		int len = strlen(preOrd);
		build(len, preOrd, inOrd, postOrd);
		postOrd[len] = ‘\0‘;
		printf("%s\n", postOrd);
	}	
	return 0;
}



以上是关于UVA - 536 Tree Recovery的主要内容,如果未能解决你的问题,请参考以下文章

UVA - 536 Tree Recovery(递归建树)

UVa536 - Tree Recovery

UVa 536 Tree Recovery | GOJ 1077 Post-order (习题 6-3)

习题6_3 二叉树重建(Tree Recovery, ULM 1997, UVa536)

习题6_3 二叉树重建(Tree Recovery, ULM 1997, UVa536)

UVa536 Tree Recovery (二叉树遍历)