1019. General Palindromic Number (20)

Posted 王清河

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1019. General Palindromic Number (20)相关的知识,希望对你有一定的参考价值。

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1
#include<cstdio>
int judge(int ans[],int num){
    for(int i = 0; i <= num/2; i++){
        if(ans[i] != ans[num - i -1])
        return 0;
    }
    return 1;
}
int main(){
    int n,b,ans[40],num = 0;
    scanf("%d%d",&n,&b);
    do{
        ans[num++] = n % b;
        n /= b;
    }while(n != 0);
     
    if(judge(ans,num)) printf("Yes\n");
    else printf("No\n");
    for(int i = num-1; i >= 0; i--){
        printf("%d",ans[i]);
        if(i != 0) printf(" ");
    }
    
    return 0;
}
#include<cstdio>
bool judge(int ans[],int num){
    for(int i = 0; i <= num/2; i++){
        if(ans[i] != ans[num - i -1])
        return false;
    }
    return true;
}

int main(){
    int n,b,ans[40],num = 0;
    scanf("%d%d",&n,&b);
    do{
        ans[num++] = n % b;
        n /= b;
    }while(n != 0);
    bool flag = judge(ans,num);
    if(flag == true) printf("Yes\n");
    else printf("No\n");
    for(int i = num-1; i >= 0; i--){
        printf("%d",ans[i]);
        if(i != 0) printf(" ");
    }

    
    return 0;
}

 

以上是关于1019. General Palindromic Number (20)的主要内容,如果未能解决你的问题,请参考以下文章

1019 General Palindromic Number

1019. General Palindromic Number (20)

1019. General Palindromic Number (20)

PAT 1019 General Palindromic Number[简单]

1019. General Palindromic Number待更新

1019 General Palindromic Number (20分)