poj 2485 Prim裸

Posted ZZUGPY

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 2485 Prim裸相关的知识,希望对你有一定的参考价值。

Highways
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 34492   Accepted: 15570

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They‘re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692


此题为最小生成树入门题,裸prim水过就可以了,求最短路径的最长线段

#include<iostream>
#include<cstring>
using namespace std;

const int INF = 0x3f3f3f;
const int MAXN = 500;
int map[MAXN+1][MAXN+1];
int dis[MAXN+1];
bool visited[MAXN+1];
 
int prim(int n)
{
    int visit,max_line = -INF,min_path;
    memset(visited,false,sizeof(visited));
    visited[0] = true;
    for(int i = 0;i<n;i++)
        dis[i] = map[0][i];
    for(int j = 1;j<n;j++)
    {
        min_path = INF;
        for(int i = 0;i<n;i++)
        {    
            if(visited[i] == false && min_path > dis[i])    
            {
                visit = i;
                min_path = dis[i];
            }
        }
        //cout<<min_path<<endl;
        if(max_line < min_path)
            max_line = min_path;
        visited[visit] = true;
        for(int i = 0;i<n;i++)
            if(visited[i] == false && dis[i] > map[visit][i])
                dis[i] = map[visit][i];
    }    
    return max_line;    
}

int main()
{
    int count,n;
    cin>>count;
    while(count--)
    {
        cin>>n;
        for(int i = 0;i<n;i++)
            for(int j = 0;j<n;j++)
                cin>>map[i][j];
        cout<<prim(n)<<endl;
    }
    return 0;
} 

 

以上是关于poj 2485 Prim裸的主要内容,如果未能解决你的问题,请参考以下文章

Highways POJ 2485Prim

POJ 2485 Highways (prim)

POJ 2485 Prim 找最长的边

POJ #2485 Highways MST中的最大边权

Poj 2485 Highways

POJ-2485 Highways---最小生成树中最大边