Error Curves HDU - 3714

Posted Fitz

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Error Curves HDU - 3714相关的知识,希望对你有一定的参考价值。

Josephina is a clever girl and addicted to Machine Learning recently. She 
pays much attention to a method called Linear Discriminant Analysis, which 
has many interesting properties. 
In order to test the algorithm‘s efficiency, she collects many datasets. 
What‘s more, each data is divided into two parts: training data and test 
data. She gets the parameters of the model on training data and test the 
model on test data. To her surprise, she finds each dataset‘s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0. 

技术分享图片


It‘s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function‘s minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it‘s too hard for her to solve this problem. As a super programmer, can you help her?

InputThe input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.OutputFor each test case, output the answer in a line. Round to 4 digits after the decimal point.Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000



这题给你n个二次函数,求出最大值的最小值。
其实就是n个二次取出每一个点去最大值,然后构成一个新的二次函数。
于是就变成了二次函数求最小值。
裸三分!


#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int a[10010],b[10010],c[10010];
int n;
double f(double x)
{
    double ans=a[0]*x*x+b[0]*x+c[0];
    for (int i=0 ;i<n ;i++){
        ans=max(ans,a[i]*x*x+b[i]*x+c[i]);
    }
    return ans;
}
int main() {
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0 ;i<n ;i++){
            scanf("%d%d%d",&a[i],&b[i],&c[i]);
        }
        double l=0,r=1000,rmid,lmid;
        while(r-l>1e-9){
            rmid=r-(r-l)/3;
            lmid=l+(r-l)/3;
            if (f(rmid)>f(lmid)) r=rmid;
            else l=lmid;
        }
        printf("%.4lf\n",f(l));
    }
    return 0;
}

 





















以上是关于Error Curves HDU - 3714的主要内容,如果未能解决你的问题,请参考以下文章

HDU 3714 Error Curves

HDU-3714 Error Curves(凸函数求极值)

[HDOJ3714]Error Curves(三分)

LA5009 Error Curves

UVA - 1476 - Error Curves

hdu3714 三分