hdu 1342.. 复习广搜 顺便练习一下一个脑残的格式

Posted 不搞事情和咸鱼有什么区别

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1342.. 复习广搜 顺便练习一下一个脑残的格式相关的知识,希望对你有一定的参考价值。

In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn‘t increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34].

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.
 

 

Input
The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k.
 

 

Output
For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.
 

 

Sample Input
7 1 2 3 4 5 6 7 8 1 2 3 5 8 13 21 34 0
 

 

Sample Output
1 2 3 4 5 6 1 2 3 4 5 7 1 2 3 4 6 7 1 2 3 5 6 7 1 2 4 5 6 7 1 3 4 5 6 7 2 3 4 5 6 7 1 2 3 5 8 13 1 2 3 5 8 21 1 2 3 5 8 34 1 2 3 5 13 21 1 2 3 5 13 34 1 2 3 5 21 34 1 2 3 8 13 21 1 2 3 8 13 34 1 2 3 8 21 34 1 2 3 13 21 34 1 2 5 8 13 21 1 2 5 8 13 34 1 2 5 8 21 34 1 2 5 13 21 34 1 2 8 13 21 34 1 3 5 8 13 21 1 3 5 8 13 34 1 3 5 8 21 34 1 3 5 13 21 34 1 3 8 13 21 34 1 5 8 13 21 34 2 3 5 8 13 21 2 3 5 8 13 34 2 3 5 8 21 34 2 3 5 13 21 34 2 3 8 13 21 34 2 5 8 13 21 34 3 5 8 13 21 34
这里比较坑爹的就是格式问题 在最后一次输出的时候不需要用空格分开。~。  
这里使用了一个小技巧
int i,flag=1;
    while(cin>>t)
 {
  if(t==0) break;
  if(flag) flag=0;
  else  cout<<endl;
大致的思想 每次输出的时候 在输出的最开始的地方输出空格 而且第一次输出是不需要空格的 这里就把flag的值做一次调整 后续的输出先判断是否为0再进行输出操作

 

#include<iostream>
#include<string.h>
#include<cstdio>
#include<algorithm>
using namespace std;
int num[100],ans[100],t;
bool cmp(int x,int y)
{
 return x<y;
}
void dfs(int time,int position)
{
 int i;
 if(time==7)
 {
  for(i=1;i<time;i++)
  {
   if(i==1) printf("%d",ans[i]);
   else printf(" %d",ans[i]);
  }
  cout<<endl;
  return;
 }
 for(i=position+1;i<=t;i++)
 {
    ans[time]=num[i];
  //  cout<<‘<‘<<ans[time]<<‘>‘;
    dfs(time+1,i);
 }
}
int main()
{
 int i,flag=1;
    while(cin>>t)
 {
  if(t==0) break;
  if(flag) flag=0;
  else  cout<<endl;
  for(i=1;i<=t;i++)
  {
   cin>>num[i];
  }
  sort(num+1,num+t,cmp);
 // for(i=1;i<=t;i++) cout<<num[i];
 // memset(vis,0,sizeof(vis));
 // vis[1]=1;
  dfs(1,0);
 }
 
 return 0;
}

以上是关于hdu 1342.. 复习广搜 顺便练习一下一个脑残的格式的主要内容,如果未能解决你的问题,请参考以下文章

hdu-1342 Lotto

hdu 1342(DFS)

双向广搜-HDU1401 Solitaire

HDU-1495 非常可乐 (嵌套结构体-广搜 对比 一般广搜)

hdu 1180(广搜好题)

HDU2612 Find a way (双广搜)