Hdoj 2509 Be the Winner

Posted 蒟蒻JHY

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Hdoj 2509 Be the Winner相关的知识,希望对你有一定的参考价值。

Diciption
Let‘s consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time. 
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win). 

Input

You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases. 
Output

If a winning strategies can be found, print a single line with "Yes", otherwise print "No". 
Sample Input

2
2 2
1
3

Sample Output

No
Yes


anti_nim游戏。
这种Nim是不能操作者赢。
Sg函数的话还是和普通的Nim一样,初始化是sg[0]=0;
最后游戏的和的话,先手必胜当且仅当:
1.每一堆石子都是1并且Nim和为0.
2.有至少一堆石子>1并且Nim和不为0.

#include<bits/stdc++.h>
#define ll long long
using namespace std;
int sg[105],n,m;
int now,v[1005];

inline void init(){
	sg[0]=0;
	for(int i=1;i<=100;i++){
		now=0;
		for(int j=0;j<i;j++)
		    for(int k=j;k+j<i;k++) v[sg[j]^sg[k]]=i;
		while(v[now]==i) now++;
		
		sg[i]=now;
	}
}

int main(){
	init();
	
	while(scanf("%d",&n)==1){
		bool flag=0;
		int a,ans=0;
		
		while(n--){
			scanf("%d",&a);
			ans^=sg[a];
			if(a>1) flag=1;
		}
		
		if((!flag&&!ans)||(flag&&ans)) puts("Yes");
		else puts("No");
	}
	
	return 0;
}

  

 

以上是关于Hdoj 2509 Be the Winner的主要内容,如果未能解决你的问题,请参考以下文章

hdu2509Be the Winner(反nim博弈)

HDU 2509 Be the Winner(取火柴博弈2)

HDU Be the Winner [Anti-SG]

Gym 100712A - Who Is The Winner

LeetCode(数据库)- The Winner University

486. Predict the Winner