1094. The Largest Generation (25)二叉树——PAT (Advanced Level) Practise

Posted 闲云阁

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1094. The Largest Generation (25)二叉树——PAT (Advanced Level) Practise相关的知识,希望对你有一定的参考价值。

题目信息

1094. The Largest Generation (25)

时间限制200 ms
内存限制65536 kB
代码长度限制16000 B
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M(小于N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

解题思路

二叉树

AC代码

#include <cstdio>
#include <vector>
using namespace std;
vector<int> node[105];
int level[105];
void dfs(int root, int lv){
    level[lv]++;
    for (int i = 0; i < node[root].size(); ++i){
        dfs(node[root][i], lv + 1);
    }
}
int main()
{
    int n, k, id, tn, t;
    scanf("%d%d", &n, &k);
    for (int i = 0; i < k; ++i){
        scanf("%d%d", &id, &tn);
        for (int j = 0; j < tn; ++j){
            scanf("%d", &t);
            node[id].push_back(t);
        }
    }
    dfs(1, 1);
    int mx = 1, mxid = 1;
    for (int i = 1; i <= n; ++i){
        if (level[i] > mx){
            mx = level[i];
            mxid = i;
        }
    }
    printf("%d %d\n", mx, mxid);
    return 0;
}

以上是关于1094. The Largest Generation (25)二叉树——PAT (Advanced Level) Practise的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1094 The Largest Generation[bfs][一般]

PAT 1094. The Largest Generation (层级遍历)

1094 The Largest Generation

1094. The Largest Generation (25)二叉树——PAT (Advanced Level) Practise

PAT 1094. The Largest Generation(BFS)

1094. The Largest Generation (25)二叉树——PAT (Advanced Level) Practise