POJ 2409 Let it Bead(Polya)

Posted 小胡子Haso

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2409 Let it Bead(Polya)相关的知识,希望对你有一定的参考价值。

【POJ 2409】 Let it Bead(Polya)

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5378   Accepted: 3596

Description

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It‘s a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced.

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.

Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

Output

技术分享For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.

Sample Input

1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0

Sample Output

1
2
3
5
8
13
21

Source


裸Polya。,经过旋转对称后一样的算一种。

这样公式套上。。。。


#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e9+7;
const double eps = 1e-8;


int main()
{
	//fread();
	//fwrite();

	int c,s;
	int ans;
	while(~scanf("%d%d",&c,&s) && (c+s))
	{
		ans = 0;
		for(int i = 1; i <= s; ++i)
			ans += (int)pow(1.0*c,__gcd(i,s));

		if(s&1) printf("%d\n",(ans+(int)pow(1.0*c,(s+1)/2)*s)/(2*s));
		else printf("%d\n",(ans+(int)pow(1.0*c,s/2)*(s/2)+(int)pow(1.0*c,(s-2)/2+2)*(s/2))/(2*s));
	}

	return 0;
}















以上是关于POJ 2409 Let it Bead(Polya)的主要内容,如果未能解决你的问题,请参考以下文章

POJ 2409 Let it Bead(置换burnside引理)

POJ 2409-Let it Bead(Polya计数)

[ACM] POJ 2409 Let it Bead (Polya计数)

POJ2409 Let it Bead

POJ2409Let it Bead Pólya定理

POJ 2409 Let it Bead [置换群 Polya]