HDOJ/HDU 2560 Buildings(嗯~水题)
Posted 谙忆
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDOJ/HDU 2560 Buildings(嗯~水题)相关的知识,希望对你有一定的参考价值。
Problem Description
We divide the HZNU Campus into N*M grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the N*M grids.
Input
Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands for green.
Output
Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.
Sample Input
2
2 2
1 1
0 0
3 3
1 0 1
0 0 1
1 1 0
Sample Output
2
5
水题一个~~
就是一个学校n*m的面积,然后有建筑~
1代表建筑,统计建筑的总数~
import java.util.Scanner;
public class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int t =sc.nextInt();
while(t-->0){
int n =sc.nextInt();
int m =sc.nextInt();
int sum=0;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
int a =sc.nextInt();
if(a==1){
sum++;
}
}
}
System.out.println(sum);
}
}
}
以上是关于HDOJ/HDU 2560 Buildings(嗯~水题)的主要内容,如果未能解决你的问题,请参考以下文章
HDOJ/HDU 1256 ???8(????????????~??????)
HDOJ/HDU 2163 Palindromes(判断回文串~)
HDOJ/HDU 1321 Reverse Text(倒序输出~)