Windows Message Queue

Posted 康栋

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Windows Message Queue相关的知识,希望对你有一定的参考价值。

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

 

Input

 

There‘s only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there‘re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

<b< dd="">

Output

 

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there‘s no message in the queue, output "EMPTY QUEUE!". There‘s no output for "PUT" command.

<b< dd="">

Sample Input

 

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

<b< dd="">

Sample Output

 

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

 

#include<iostream>
#include<string >
#include<queue>
#include<map>
using namespace std;
struct kang
{
    char k[220];
    int a, b, c;
};
map<int, int> ko;
bool operator < (const kang & a, const kang & b)
{
    if (a.b != b.b)
        return a.b > b.b;
    return  a.c > b.c;
}
int main()
{
    priority_queue<kang> k;
    char str[10];
    while (cin >> str)
    {
        if (str[0] == G)
        {
            if (k.empty())
                cout << "EMPTY QUEUE!" << endl;
            else
            {
                kang kg;
                kg = k.top();
                k.pop();
                cout << kg.k <<" "<< kg.a << endl;
            }
        }
        else
        {
            kang kg;
            cin >> kg.k >> kg.a >> kg.b;
            kg.c = ko[kg.b]++;
            k.push(kg);
        }
    }
    return 0;
}

 

以上是关于Windows Message Queue的主要内容,如果未能解决你的问题,请参考以下文章

Windows Message Queue

Windows Message Queue

Windows Message Queue(优先队列)

HDU 1509 Windows Message Queue

hdu1509(Windows Message Queue) 优先队列

zoj 2724 Windows Message Queue(使用priority_queue容器模拟消息队列)