P2922 [USACO08DEC]秘密消息Secret Message

Posted alex-leaves

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了P2922 [USACO08DEC]秘密消息Secret Message相关的知识,希望对你有一定的参考价值。

题目描述

Bessie is leading the cows in an attempt to escape! To do this, the cows are sending secret binary messages to each other.

Ever the clever counterspy, Farmer John has intercepted the first b_i (1 <= b_i <= 10,000) bits of each of M (1 <= M <= 50,000) of these secret binary messages.

He has compiled a list of N (1 <= N <= 50,000) partial codewords that he thinks the cows are using. Sadly, he only knows the first c_j (1 <= c_j <= 10,000) bits of codeword j.

For each codeword j, he wants to know how many of the intercepted messages match that codeword (i.e., for codeword j, how many times does a message and the codeword have the same initial bits). Your job is to compute this number.

The total number of bits in the input (i.e., the sum of the b_i and the c_j) will not exceed 500,000.

Memory Limit: 32MB

输入输出格式

输入格式:

* Line 1: Two integers: M and N

* Lines 2..M+1: Line i+1 describes intercepted code i with an integer b_i followed by b_i space-separated 0‘s and 1‘s

* Lines M+2..M+N+1: Line M+j+1 describes codeword j with an integer c_j followed by c_j space-separated 0‘s and 1‘s

 

输出格式:

* Lines 1..M: Line j: The number of messages that the jth codeword could match.

 

输入输出样例

输入样例#1: 复制
4 5 
3 0 1 0 
1 1 
3 1 0 0 
3 1 1 0 
1 0 
1 1 
2 0 1 
5 0 1 0 0 1 
2 1 1 
输出样例#1: 复制
1 
3 
1 
1 
2 

说明

Four messages; five codewords.

The intercepted messages start with 010, 1, 100, and 110.

The possible codewords start with 0, 1, 01, 01001, and 11.

0 matches only 010: 1 match

1 matches 1, 100, and 110: 3 matches

01 matches only 010: 1 match

01001 matches 010: 1 match

11 matches 1 and 110: 2 matches

 

第一道英文题,有点小激动……

由题意知我们可以把0 1看成字符串,设sum表示经过的已知字符个数,end表示以该节点结束的字符……

然后第一种:询问到尽头,那就是答案-end+sum(想想,为什么?),

不然就是答案。

AC代码如下(看过其他题解,不一定最快,但是最简单的)

#include<cstdio>
using namespace std;
const int N=500000+5;
int ch[N][2],sum[N],end[N];
int x,l,n,m,u,tot,ans;
bool ff;
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&l);
        u=0;
        for(int j=1;j<=l;j++)
        {
            scanf("%d",&x);
            if(!ch[u][x]) ch[u][x]=++tot;
            u=ch[u][x];
            sum[u]++;
        }
        end[u]++;
    }
    for(int i=1;i<=m;i++)
    {
        scanf("%d",&l);
        ans=u=0;ff=1;
        for(int j=1;j<=l;j++)
        {
            scanf("%d",&x);
            if(ff&&ch[u][x]) u=ch[u][x];
            else ff=0;
            if(ff) ans+=end[u];
        }
        if(ff) printf("%d\n",ans-end[u]+sum[u]);
        else printf("%d\n",ans);
    }
    return 0;
}

 

以上是关于P2922 [USACO08DEC]秘密消息Secret Message的主要内容,如果未能解决你的问题,请参考以下文章

P2922 [USACO08DEC]秘密消息Secret Message

P2922 [USACO08DEC]秘密消息Secret Message

P2922 [USACO08DEC]秘密消息Secret Message

洛谷 P2922 [USACO08DEC]秘密消息Secret Message

P2922 [USACO08DEC]秘密消息Secret Message

P2922 [USACO08DEC]Secret Message G(Trie)