Arithmetic Sequence(dp)

Posted handsomecui

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Arithmetic Sequence(dp)相关的知识,希望对你有一定的参考价值。

Arithmetic Sequence

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 51  Solved: 19
[Submit][Status][Web Board]

Description

    Giving a number sequence A with length n, you should choosingm numbers from A(ignore the order) which can form an arithmetic sequence and make m as large as possible.

Input

 

   There are multiple test cases. In each test case, the first line contains a positive integer n. The second line contains nintegers separated by spaces, indicating the number sequenceA. All the integers are positive and not more than 2000. The input will end by EOF.

 

Output

 

   For each test case, output the maximum  as the answer in one line.

 

Sample Input

5
1 3 5 7 10
8
4 2 7 11 3 1 9 5

Sample Output

4
6

HINT

 

 


 


   In the first test case, you should choose 1,3,5,7 to form the arithmetic sequence and its length is 4.


   In the second test case, you should choose 1,3,5,7,9,11 and the length is 6.

题解:等差数列最长长度;开个二维dp,记录下就好了;一维dp也能过。。。
java超时;c过;
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[2010][2010];
int a[2010];
int main(){
    int N;
        while(~scanf("%d", &N)){
            for(int i = 0; i < N; i++){
                scanf("%d", a + i);
            }
            sort(a, a + N);
            int ans = 1; 
            for(int i = 0; i < N; i++){
                for(int k = 0; k <= 2000; k++){
                        dp[i][k] = 0;
                }
            }
            for(int i = 0; i < N; i++){
                for(int j = 0; j < i; j++){
                    int d = a[i] - a[j];
                    dp[i][d] = dp[j][d] + 1;
                    ans = max(ans, dp[i][d] + 1);
                }
            }
            printf("%d\n", ans);
            }
    return 0;
}

java:

import java.util.Arrays;
import java.util.Scanner;

public class  ArithmeticSequence{
    static int[][] dp = new int[2010][2010];
    public static void main(String[] args){
        Scanner cin = new Scanner(System.in);
        int N;
        while(cin.hasNext()){
            N = cin.nextInt();
            int[] a = new int[N];
            for(int i = 0; i < a.length; i++){
                a[i] = cin.nextInt();
            }
            Arrays.sort(a);
            int ans = 1; 
            for(int i = 0; i < N; i++){
                for(int k = 0; k <= 2000; k++){
                        dp[i][k] = 0;
                }
            }
            for(int i = 0; i < a.length; i++){
                for(int j = 0; j < i; j++){
                    int d = a[i] - a[j];
                    dp[i][d] = dp[j][d] + 1;
                    ans = Math.max(ans, dp[i][d] + 1);
                }
            }
            System.out.println(ans);
        }
    }
}

 dp;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[2010];
int a[2010];
int main(){
    int N;
        while(~scanf("%d", &N)){
            for(int i = 0; i < N; i++){
                scanf("%d", a + i);
            }
            sort(a, a + N);
            int ans = 1; 
                for(int i = 0; i <= 2000; i++){
                    for(int k = 0; k <= 2000; k++){
                        dp[k] = 0;
                }
                for(int j = 0; j < N; j++){
                    if(a[j] >= i)dp[a[j]] = max(dp[a[j] - i] + 1, dp[a[j]]);
                    else dp[a[j]] = 1;
                        ans = max(ans, dp[a[j]]);
                }
            }
            printf("%d\n", ans);
            }
    return 0;
}

 

以上是关于Arithmetic Sequence(dp)的主要内容,如果未能解决你的问题,请参考以下文章

hdu 5400 Arithmetic Sequence

hdu 5400 Arithmetic Sequence

[动态规划] leetcode 1027 Longest Arithmetic Sequence

the arithmetic sequence of integers

HDU 5400 Arithmetic Sequence

leetcode1027. Longest Arithmetic Sequence