hdu 1690(Floyed)

Posted AC菜鸟机

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1690(Floyed)相关的知识,希望对你有一定的参考价值。

Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8055    Accepted Submission(s): 2121


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.

技术分享


Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

 

Sample Input
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

 

Sample Output
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
 
注意这题INF要很大。。我就是因为INF开小了一点点就WA了。
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
#include <stdlib.h>
using namespace std;
typedef long long ll;
const ll INF =111111111111;
const int N = 105;
ll graph[N][N];
ll L[4],C[4];
ll x[N];
ll check(ll dis){
    if(dis<=L[0]) return C[0];
    else if(dis>L[0]&&dis<=L[1]) return C[1];
    else if(dis>L[1]&&dis<=L[2]) return C[2];
    else if(dis>L[2]&&dis<=L[3]) return C[3];
    return INF;
}
int main()
{
    int tcase;
    scanf("%d",&tcase);
    int t = 1;
    while(tcase--){
        for(int i=0;i<4;i++){
            scanf("%lld",&L[i]);
        }
        sort(L,L+4);
        for(int i=0;i<4;i++){
            scanf("%lld",&C[i]);
        }
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++){
            scanf("%lld",&x[i]);
        }
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                if(i==j) graph[i][j] = 0;
                else{
                    ll dis = abs(x[i]-x[j]);
                    graph[i][j]=check(dis);
                }
            }
        }
        for(int k=0;k<n;k++){
            for(int i=0;i<n;i++){
                if(graph[k][i]<INF){
                    for(int j=0;j<n;j++){
                        graph[i][j] = min(graph[i][j],graph[i][k]+graph[k][j]);
                    }
                }
            }
        }
        printf("Case %d:\n",t++);
        while(m--){
            int a,b;
            scanf("%d%d",&a,&b);
            int c = a-1,d=b-1;
            if(graph[c][d]>=INF) printf("Station %d and station %d are not attainable.\n",a,b);
            else printf("The minimum cost between station %d and station %d is %lld.\n",a,b,graph[c][d]);
        }
    }
}

 

以上是关于hdu 1690(Floyed)的主要内容,如果未能解决你的问题,请参考以下文章

hdu1690Bus System--解题报告

hdu 1863 [最小生成树+hdu2544floyed+hdu1874dijdtra~~~模板复习~~~

[ACM] hdu 1217 Arbitrage (bellman_ford最短路,推断是否有正权回路或Floyed)

定位仿真基于matlab RSSI三边定位仿真含Matlab源码 1690期

Fibonacci String(hdu 1708)

codevs1690开关灯