PAT 1090. Highest Price in Supply Chain

Posted A-Little-Nut

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1090. Highest Price in Supply Chain相关的知识,希望对你有一定的参考价值。

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

分析

用邻接表法建树,dfs遍历,不难

#include<iostream>
#include<vector>
#include<math.h>
using namespace std;
int cnt=0,level=0,visited[100005]={0};
double p,r,maxprice=-1;
vector<int> G[100005];
void dfs(int s){
     level++;
     if(G[s].size()==0){
        if(p*pow(1+0.01*r,level-1)>maxprice){
            cnt=1;
            maxprice=p*pow(1+0.01*r,level-1);
        }else if(p*pow(1+0.01*r,level-1)==maxprice)
            cnt++; 
     }
     for(int i=0;i<G[s].size();i++)
            dfs(G[s][i]);
     level--;
} 
int main(){
    int n,t,s;
    cin>>n>>p>>r;
    for(int i=0;i<n;i++){
        cin>>t;
        if(t==-1) s=i;
        else G[t].push_back(i); 
    }   
    dfs(s);
    printf("%.2lf %d",maxprice,cnt);
    return 0;
} 

以上是关于PAT 1090. Highest Price in Supply Chain的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1090 Highest Price in Supply Chain[较简单]

1090. Highest Price in Supply Chain (25)树——PAT (Advanced Level) Practise

PAT (Advanced Level) Practice 1090 Highest Price in Supply Chain (25 分) 凌宸1642

1090. Highest Price in Supply Chain (25)树——PAT (Advanced Level) Practise

1090 highest price in supply chain

PAT (Advanced Level) 1090. Highest Price in Supply Chain (25)