POJ 2823 Sliding Window

Posted Ed_Sheeran

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2823 Sliding Window相关的知识,希望对你有一定的参考价值。

Sliding Window
链接:http://poj.org/problem?id=2823
Time Limit: 12000MS   Memory Limit: 65536K
     
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

 
题意:给定一个数列,从左至右输出每个长度为m的数列段内的最小数和最大数。
数列长度:N<=106m<=N
#include<iostream>
#include<cstdio>
using namespace std;

const int N = 1000005;

int n,k,m,mn[N],mx[N],n1,n2;

struct node{
    int id, data;
};node dj[N],dz[N];//dz 递增队列 dj 递减队列 

int main()
{
    cin >> n >> k;
    int headj = 1,tail1 = 0,headz = 1,tail2 = 0;
    for(int i = 1; i <= n; i++){
        scanf("%d",&m);
        while(m <= dj[tail1].data && tail1 >= headj) tail1 --;//保持单调性 
        while(m >= dz[tail2].data && tail2 >= headz) tail2 --;
        dj[++tail1].data = m;dj[tail1].id = i;
        dz[++tail2].data = m;dz[tail2].id = i;
        if(i >= k){
            //开始记录第n段中的最值 
            if(dj[headj].id <= i-k) mn[++n1] = dj[++headj].data;//过期了 
            else mn[++n1] = dj[headj].data;
            if(dz[headz].id <= i-k) mx[++n2] = dz[++headz].data;
            else mx[++n2] = dz[headz].data;
        }
    }
    for(int i = 1; i <= n1; i++)
        printf("%d ",mn[i]);
    cout<<endl;
    for(int i = 1; i <= n1; i++)
        printf("%d ",mx[i]);
    return 0;
}

第一次手打队列,以后还是用双向吧

以上是关于POJ 2823 Sliding Window的主要内容,如果未能解决你的问题,请参考以下文章

POJ 2823 Sliding Window 题解

POJ 2823 Sliding Window 单调队列

POJ 2823 Sliding Window

POJ 2823 Sliding Window

POJ 2823 Sliding Window

POJ2823 Sliding Window