A Mini Locomotive(01背包变型)

Posted Reqaw’s Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了A Mini Locomotive(01背包变型)相关的知识,希望对你有一定的参考价值。

题目链接:

https://vjudge.net/problem/POJ-1976

题目描述:

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows: 

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives. 
2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches. 
3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1. 

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60. 

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers. 

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives. 

Input

The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches. 

Output

There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.

Sample Input

1
7
35 40 50 10 30 45 60
2

Sample Output

240

题意描述:
输入车厢的节数和每节车厢的人数以及每个火车头最多能拉几节车厢数
计算并输出三个火车头最多能拉多少人
解题思路:
参加代码中的注释。
代码实现:
#include<stdio.h>
#include<string.h>
const int N=50100;
int qmsum[N],s[N];
int f[N][4];
int max(int x, int y){
    return x > y ? x : y;
} 
/*
问题 前i节车厢用j个火车头拉,最多能拉多少人,其中每个火车头拉m节连续的车厢 
变量 i,j
状态 f[i][j]表示 前i节车厢用j个火车头拉,最多能拉多少人
每种状态面临两种取法,取以第i节车厢为首的m节车厢,不取以第i节车厢为首的m节车厢
状态转移方程为f[i][j]=max(f[i-m][j-1] + (sum[i]-sum[i-m]) , f[i-1][j]); 
其中sum[i]-sum[i-m]为每段车厢的人数和 
*/
int main()
{
    int T,n,i,j,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&s[i]);
            qmsum[i]=qmsum[i-1]+s[i];//前i节车厢中有多少人 
        }
        scanf("%d",&m);
        
        memset(f,0,sizeof(f));
        for(i=m;i<=n;i++)
            for(j=3;j>=1;j--)
                f[i][j]=max(f[i-1][j] , f[i-m][j-1] + (qmsum[i]-qmsum[i-m]));
                
        printf("%d\n",f[n][3]);
    }
    return 0;
}

 

以上是关于A Mini Locomotive(01背包变型)的主要内容,如果未能解决你的问题,请参考以下文章

poj 1976 A Mini Locomotive

2/13 复习下背包+单调队列变型

9/5 二维费用背包+基环树+01变型背包

51nod 1101 换零钱 完全背包的变型 动态规划

8/11 二分图染色+KM算法变型+后缀数组+图论

nuxt 与 locomotive-scroll 和 gsap 问题有关的路线更改