1094. The Largest Generation (25)

Posted 给杰瑞一块奶酪~

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1094. The Largest Generation (25)相关的知识,希望对你有一定的参考价值。

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID‘s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

记录每个点的父亲,然后算每个点的高度然后记录每层人数,统计记录。
代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iomanip>
using namespace std;
int nn,n,f[105],num[105];
int id,k,subid,m,t;
int height(int k)
{
    if(k == 0)return 0;
    return height(f[k]) + 1;
}
int main()
{
    cin>>nn>>n;
    for(int i = 0;i < n;i ++)
    {
        cin>>id>>k;
        for(int j = 0;j < k;j ++)
        {
            cin>>subid;
            f[subid] = id;
        }
    }
    for(int i = 1;i <= nn;i ++)
    {
        int d = height(i);
        num[d] ++;
        if(num[d] > m)m = num[d],t = d;
    }
    cout<<m<< <<t;
}

 

以上是关于1094. The Largest Generation (25)的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1094 The Largest Generation[bfs][一般]

PAT 1094. The Largest Generation (层级遍历)

1094 The Largest Generation

1094. The Largest Generation (25)二叉树——PAT (Advanced Level) Practise

PAT 1094. The Largest Generation(BFS)

1094. The Largest Generation (25)二叉树——PAT (Advanced Level) Practise